Serious ghosting/low quality issue

I finally got around to trying out a movie on my new Vero4K and have discovered that for some reason video playback has severe ghosting and blocking, I’m watching 16mbps video and it looks like a 700MB avi from the early 2000s PLUS ghosting. I’m not sure if it’s something to do with the device or something else in my setup but I’m posting anyway while I investigate in case anyone else has experienced it so I can fix it.

EDIT: The video files are fine, work perfectly on my PC and (worked) on my old RPi2. I haven’t retested with the RPi2 though.

Then include a better description of your setup? You are telling us there is a problem but you aren’t giving is any info to work with. Debug enabled logs demonstrating the issue and mediainfo output of a problematic file would be a good start.

Well the description would have to include literally everything, like that I’m using Emby as a backend, ethernet, my TV model (I changed some aspect settings on it to avoid overscan fixes recently) etc. Literally everything.

I have ruled out any network issues though as I put a file onto a USB and the same display issues occurred. The menu seems perfectly fine (I have lots of background/cover art images) especially in comparison to playback. The issue only seems to exist during playback. Mediainfo wouldn’t help, I know the files are solid and have even viewed them on this TV before using the old RPi2.

I will test the old device tomorrow and hopefully it narrows down whether the issue is with the Vero or the TV.

Mediainfo would still help to diagnose if the vero has problems with a codec the PC doesn’t have.

Also debug logs will help to see if there is anything wrong with kodi or the os.

So you should post those especially if the file works on other systems.

Does Emby do transcoding or anything like that?

MediaInfo and a debug log is definitely needed. Even a small sample of the file so I can test it locally would be helpful.


Yes. Transcoding · MediaBrowser/Wiki Wiki · GitHub

Transcoding is disabled and even if it wasn’t, the last device set up identically wasn’t having the issue. Most importantly though as I have already stated the same issue is occurring playing it raw off a USB drive.

I will upload a sample shortly.

A debug log when playing back the file will also be great.


Here’s the log, for the purpose of the test I disabled the Emby plugin to try and reduce log noise and up privacy but it seems to be dug deep and threw a (harmless) error during startup and still seems to have entries in the log (actually it might have made it worse). Basically, ignore anything Emby related in the log as it was disabled and I was performing the test off a USB drive.

Steps to obtain log:

  1. Restart Kodi with debug logging enabled.
  2. Navigate Movies->[…]->[…]->Files->[USB]->sample.mkv
  3. Watch sample in entirety.
  4. Press Home button.
  5. Navigate Programs->My OSMC->Log Uploader->Upload (all) log now.
    EDIT: See post below for log created without disabling the Emby plugin (which was filling it with pointless errors unrelated to the issue).

If you find anything sensitive in the log please nuke it.

sample.mkv --sha256: 862de1de544dc132f36d9b59f5c497f6291beb288e1be674330f24ae109c96f6
I removed all tracks except the video and cut it down to ~2m using mkvtoolnix 10.0.0.

I tried to use ‘kodi-send --action=TakeScreenshot’ but apparently video playback is just black and only the UI shows.

One thing I did notice was that during playback the OSD debug log text was saying it was only displaying ~15-19fps (it jumped up and around a lot, sometimes over 20), I don’t know if it normally says that but shouldn’t it just hang at 24?

Silly question here, but have you tried a different HDMI cable? It could be the cable.

I’d try out your sample here, but with satellite internet, it’s to much for me to download :frowning:

I have not, I switched to the HDMI cable that came with the device but I could try my old one. I still have to try the old device entirely but I’ve been lazy, might do it now.

Would you like a smaller sample? I could probably cut it down to 20s to get the really filthy parts.

Try switching the cable first.

Tried switching the cable, no difference. Tried the old device (RPi2) and while the picture doesn’t look as good as it does on my PC (maybe because it’s a ‘large’ TV and I’m 10cm from it) there’s no ghosting issue. I checked twice to be sure and the Vero4K is definitely ghosting the image and the RPi2 is not.

Without being able to record or take screenshots of it the best comparison I can give is that when people walk around on the screen they look like your mouse does in Windows when you turn on pointer trails. It causes extreme blocking and faces without detail.

I’m 99% sure that static parts of the image are also degraded but can’t confirm it, they could be being distorted by a ghosting of the statistical grain noise.

I hadn’t looked at your logs yet, but just did. And it’s full of:

12:38:45.017 T:3296814064   DEBUG: CPythonInvoker(155, /home/osmc/.kodi/addons     / instantiating addon using automatically obtained id of "" dependent on version 2.19.0 of the xbmc.python api
12:38:45.194 T:3296814064   ERROR: EXCEPTION: Unknown addon id ''.
12:38:45.196 T:3296814064   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                         - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                        Error Type: <type 'exceptions.RuntimeError'>
                                        Error Contents: Unknown addon id ''.
                                        Traceback (most recent call last):
                                          File "/home/osmc/.kodi/addons/", line 15, in <module>
                                            _addon = xbmcaddon.Addon(id='')
                                        RuntimeError: Unknown addon id ''.
                                        -->End of Python script error report<--
12:38:45.200 T:3296814064    INFO: Python script stopped

So if you can, try to remove Emby. It causing lots of errors!

Like I said, I disabled the plugin for the test but I guess there are other parts of it worked in somewhere and it started throwing up because the primary plugin was disabled. I’d guess that those errors can be ignored and were caused by disabling the plugin, if you want I can take the log again without disabling it.

EDIT: Here’s the log created using the same method but without disabling the Emby plugin (which I’m not using for this test),

As you can see, those errors are gone. Issue was still apparent though.

Since it’s late at night here, I was able to download your sample, and it plays perfectly on my Vero 4K.

Is there some way to record or screenshot video playback or is that beyond the power of the device?

Press Print Screen on a keyboard.

That would work where ‘kodi-send --action=TakeScreenshot’ did not? Will it just save to ~?

Both will work.
I believe Kodi prompts you to save path the first time you run this.