Serious ghosting/low quality issue

Did for me though, disabling hardware decoding fixed the issue entirely, or appeared to. Confirmed this on two TVs and a PC monitor, all three of which had the issue apparent with hardware decoding enabled.

1 Like

Thanks, that makes it easier to track things down.
There may be an unrelated issue for those who experience the problem with hardware decoding disabled.

Sam

Hi,

Sorry for the intrusion, but I think I could add some info to the case.
I experienced the problem as described by the others in this thread.
(Ghosting with H.264 / 1080p content, mostly in dark scenes, especially on faces)
I wanted to exclude that the media I was playing was not problematic by itself, so I copied it to a usb stick, attached it to TV, and played directly from TV.
As I was expecting, I could not reproduce the problem,
BUT
The TV (4K Samsung 2016) has a “Digital Clean View” setting. When I enabled it, the problem was there again, although I was playing the media without the Vero 4K.
This ‘Digital Clean View” setting is supposed to improve quality when viewing SD content (DVD or SD TV). So I was thinking that a similar setting is unnecessarily enabled in the OSMC all the time, and causing the problem.
It is just a thought, might help Sam.

Thanks for your time, hope the solution to be included to May update.

Are you saying that if you disable ‘Digital Clean View’, then you do not see the issue anymore?

I don’t see the issue Only when i play content from a usb stick directly attached on TV and setting is OFF.
When I play from the VERO 4K the problem is there whatever the
"Digital Clean View” is ON or OFF.

Is this issue the same as I reported here?

I can’t tell if it’s the exact same issue based on your sample but it probably stems from the same problem. Seems very similar.

Yes, I would say your description is what I see too.

Hopefully all will be fixed with Sunday’s update.

@sam_nazarko Happy to test early :slight_smile:

Stay tuned!

Hi Sam. Sunday has come and gone. Have I missed something or do you have a hold up in the release?
If you need some testing I’m happy to help.
Thanks
-Mat

1 Like

Guess he is working on it, to see if its added to the project you could check git commits. It was bank holiday in the UK and even Sam deserves a break once in a while :slight_smile:

3 Likes

Hi @mlavende

The fixes we pushed for the security vulnerability delayed us slightly, but the May update is now out.

For Vero 4K:

  • We added improvements to remote responsiveness
  • We’ve added support for a lot more DVB tuners (that will please @danialbehzadi)
  • We’ve added support for RC5 remotes (including original Vero remote)

I wanted to add a fix for this ghosting issue, but the simple fact is that with some testing I’ve been unable to yet get a consensus. With some planned improvements users that were never afflicted with the issue now report ghosting, and some users that had the problem before now say it’s gone. I’m not quite sure if the same clips were tested yet.

It’s become evident to me that this is more than an issue with the hardware decoder. The issue is the hdmitx output and dithering that’s occurring.

The rework of video on Vero 4K is quite large. So instead I wanted to get this update out the door and then set up a test thread for video improvements where we can spend as much time as necessary getting things right. Keep your eyes peeled for that. There was a large (under the hood) undertaking with this update, which makes the next set of changes possible to include. With any luck, everything will behave the same. If we’re unlucky, things will regress.

Cheers, and thanks for your patience.

Sam

Good to hear it’s on the road map, unfortunate to hear that it’s such a complicated issue. Hopefully you guys can work it out though. If you need any testing done I’m sure many of us will happily do so.

Thanks Sam,

it’s definitely a hardware decoding issue and I’m more than happy to help with as much testing as needed to sort this - it’s the only thing stopping the Vero being everything it should be.

Cheers

-Mat

Just to add - disabling hardware acceleration does fix the issues with H264 files. I was incorrect previously - I set up the Kodi iOS app and added a shortcut to disable hardware acceleration whilst I was watching the file, but unaware this didn’t do anything as it needs to be changed before the file is playing.

Not sure if this adds anything, but I just wanted to share.

Improvements are coming. I’ll ping you when things are ready for some evaluation.

Sam

Hi Sam,

I’m at work so unable to test the new build I’ve just read about. Are there fixes in it for this issue please? Should I be getting hopeful :slight_smile:
Thanks for all your efforts

-Mat

Hi Mat,

There were quite a few video improvements in this update.
Because of some of the skipping reports and for stability purposes, we split the video changes in to two parts. There will be a new test thread shortly so that I can get some further feedback before integrating any changes in to OSMC proper.

Sam

Let me know where the test thread is as I’d like to help testing!

Me too! :slightly_smiling_face: