Server on different subnet unavailable


I have just moved my Vero 4K+, and it is now on a different subnet to my media server. ( The server is on the subnet, the Vero on the subnet)

Everything is fully routed between the subnets, including broadcast packets, and from Windows I can browse the server without issues. Kodi running on Windows can see the server across subnets, and even shows it in a UPnp search.
I have an old Patriot media player that can see the server across the subnets, and will play media off it perfectly.

When I try with the Vero, the server will not show in a UPnP search. If I add the server manually using it’s IP address, I get a message that it is not available.

I have checked every setting I could think of, and can’t spot anything wrong.
Is there something at system level that is causing this, is there anything I can do?

Thank you


Check the output of route.
I’m not a networking guy though, so might not be able to help much

I’m not sure if UPNP works across multiple subnets


I’ve got UPnP working across subnets on both Windows machines and an old Patriot media player, so yes it does work. I just doesn’t seem to work on the 4K+

How do I run route?



First off, we know nothing about your server, your network configuration, whether you’re using VLANs, or even the reason why you’ve moved the client(s) and server onto different subnets.

Multicast, which DLNA/UPnP uses, doesn’t normally work across subnets unless you configure something like IGMP. Unfortunately, IGMP support in domestic routers is patchy at best. How have you dealt with multicast across the subnets on your network?

I’d also ask whether you’re absolutely sure you want to use DLNA/UPnP with OSMC? DLNA/UPnP is a useful plug-and-play system that has its place with dumb appliances like TVs, but OSMC is considerably more configurable than your average TV. We might end up spending a lot of time and energy trying to get DLNA/UPnP to work when using SMB or NFS might have been possible all along.


So I haven’t randomly moved devices across subnets for the hell of it. I have taken the Vero 4K to different location, which is connected back to my servers network using a router-to-router VPN connection, which is fully routed - including multicast packets.
As I’ve stated, I have other devices that are quite happy and are working, so I have no doubt that the network is performing as expected.

The server is a Windows 2008 server, running Twonky Media Server. I was attempting to use DLNA/UPnP because it presents a consistent file list across the different types of device I have, needs no passwords etc. This is quite important to me, as it is not just me that uses them, so I am trying to keep things as consistent as I can across the 3 or 4 media player types I have.

I have tried setting up an NFS connection, but that also failed - even using the servers IP address. (Yes I do have a share for the media) I’m going to investigate that further, but I do want to make sure there is nothing in OSMC or on the device that is preventing sending / receiving across subnets.


echo 1 > /proc/sys/net/ipv4/ip_forward may help

You may need to add a route for the other subnet.


1 Like

I won’t know how (or why) you’ve set things up unless you tell me. That is why I ask questions.

So you’ have a VPN connection to the remote server. If that’s using OpenVPN, are you using a TAP connection? Again, it’s not information you’ve shared.

Anyway, we can see what multicast traffic the Vero4K+ is receiving using tcpdump. Let it run for 60 seconds and see what’s coming through:

sudo tcpdump -n "multicast"