Set a default video mode on power on even if connected display switched off

Hi all,

First time poster, with two Vero 4K units. I have one connected to a Denon AVR-X4200W receiver and Epson EH-TW9300 projector (cinema room), and another connected to a Panasonic TX-55AS802 television (living room).

I like to set the Vero 4K in the cinema room to 1080/24p for the Kodi interface because it prevents the delays between refresh rate switching when playing movies. Refresh rate switching works absolutely fine in Kodi and I have customised it with my advancedsettings.xml file to get it to work the way I prefer.

Whenever I reboot the Vero 4K, both the receiver and projector have to be on for Kodi to boot in 24Hz. If either device in the chain is off, Kodi boots in 60Hz mode and switching output modes for video does not happen. I then have to reboot Kodi when the receiver and projector are on to get it back to 24Hz menus and automatic refresh rate changing again.

While I can force the output refresh rate by adding the setting into my advancedsettings.xml, this disables refresh rate switching and also doesn’t allow Kodi to automatically switch to 3840x2160 resolution for 4K videos, meaning I am stuck with 1080/60p.

I guess the long and short of my query is, is there a way to force a primary boot resolution / refresh rate at the OSMC level, but not block Kodi from managing refresh rate changes? Kodi defaults to 1080/60p but I’d like it to default to 1080/24p even when it can’t see the connected devices.

The reason for this is that whenever there is an update to OSMC, I like to install it via the command line then reboot each system while I am at work; that way I don’t have to wait for updates to install when I get home.

Hi @TheDarkKnight,

look at the second post of Any way to persist HDMI edid data?.
Is this also a solution for you?

Ah, of course, EDID data! Thanks!

I will try this tonight and see if it fixes my issue…

Automatic re-reading of EDID is being worked on. Should be in the next update. Meanwhile, note that you don’t have to re-boot to update the display modes, just re-start Kodi (Power->Exit). Slightly faster.

1 Like

Just to confirm, @JimKnopf’s suggestion worked!


Just curious… I guess you don’t have the “no sound” issue as I reported in my edid post?

Nope, sorry I don’t have any issues with sound at all. I hope you find the source of your problem! :slight_smile: