Set omxplayer as default when both omx & mmal selected?

Currently when both OMX and mmal are selected mmal gets used as default. I prefer OMX as video doesn’t stutter when I navigate through menus.

I need mmal selected as sound works using a usb soundcard as omx doesnt. Is there way to set OMX as default when both selected and make mmal kick in when using USB soundcard.


When omxplayer and MMAL are both enabled, omxplayer is used by default unless you are using something incompatible with omxplayer.
These are:
ALSA audio
software video decode
transcode to AC3
DVD images

If you don’t believe any of those are active, then post a debug log.

Hi popcornmix

Thanks for info. Well I tested an mp4 file which has aac audio with both OMX and mmal enabled and it uses mmal.

I don’t see a setting for software encode. I remember seeing that in helix if I recall.

I haven’t my laptop available for debug get a look tomorrow.

Cheers again

If the video is a format without hardware decode support (e.g. msmpeg / divx3 / sorenson spark) then omxplayer can’t be used.
Most files are H.264 or MPEG-4 which are supported by omxplayer, but there are many other less used formats.