Setting a NAS as download directory of Transmission [Pi2]

Hi fellow pi users. Just signed up here to post about this because I didn’t find anything on the Internet about it.

I have a NAS (a Western Digital “MyBookLive”) wired to my router via USB, and I would like to save files I download from my Pi, thanks to the torrent server Transmission, to this NAS.

Since I can see what’s on this storage from Windows in the network section, I thought it used the SMB protocol that I set up on the pi already.

So I’m trying to change the path of downloads from the web GUI interface of Transmission to something like “smb://the_NAS_ip/whatever_directory”, and I got a permission denied error.

Does this mean the path is wrong? Or does this mean I need to modify some permissions from the pi?

Anyway, I know this is possible and I would love if someone let me know what I am missing here…

Thanks for reading

Transmission doesn’t know what the ‘smb://’ URI is. That is done by Kodi’s VFS layer automatically, but doesn’t work in other applications.

Instead, you should look at adding your network share to /etc/fstab and mounting it to a directory. Then you can specify the mount directory. To prevent a race condition, you may wish to set up the mount as a systemd unit. This will allow you to use a drop in with transmission.service and ensure that the share is mounted before Transmission starts.


What firmware is your router using? If you can enable nfs server on the router, that would be the best way to mount the drive in OSMC. It’s possible with samba but not as fast. Also, from what I’m reading, it’s much easier using nfs. A lot less hoops to jump through.

Thanks for your answers. With Sam’s answer I began searching how to mount my network drive and fell on this website :

I have successfully downloaded multiple video files of ~1GB each with a max speed of ~300kb/s (yeah, that is slow…) so I think I will stay with this SMB solution from now on.

The Pi is working perfectly and fulfilling his role so thanks again guys