Setting CEC to work on Raspberry Pi 3 on Yamaha av HTR-3069

I have just purchased a full Yamaha sound system and have enabled the CEC in the Amp HTR-3069 and it does work on the Ps4 and Ps3 but doesn’t work in the osmc as such I’m requesting for any suitable guides on setting it to work, did check the one in the settings and it is enabled (and I assumed it should of worked from what I searched and read on this site) and when power on the amp is turned on then Raspberry gets powered up next and which the CEC should of activated so any advice would be greatly appreciated.

If you disconnect both the PlayStations, does CEC work?

Actually both consoles are off as I don’t needlessly waste power and did test with the consoles both turned on and off (including disconnected from the hdmi) and the CEC doesn’t work in the osmc still, please note my telly doesn’t support this feature so I wanted to use the remote for the av for controlling all the devices and the hdmi leads I use are full speed as well 3d and 4k compatible.

Well, first from here - HTR-3069 - Features - AV Receivers - Audio & Visual - Products - Yamaha - Singapore

*All connected devices must be HDMI CEC compatible. Some CEC compatible TVs / players may not work.

Have you tried booting the pi only after the AVR has completed it’s startup and been set to the appropriate source?

Did exactly that before resorted to posting in the first place and it still didn’t work. Did read the manual as well to see if had any hints on sorting it and it said read the instructions any device for CEC setup

You could try making a debug log with CEC component specifics enabled but unlikely that there is anything OSMC could do. You would want to file a bug report with pulse-eight on their GitHub.

Guessed as much, did come here first since there is loads of information as well extremely knowledgeable people and if you know how to search for it using the sites search engine, so thanks ActionD for trying to help me out my specific issue.