Setting static IP address fails with error message


after installation of osmc via osmc installer it is not possible to set up static ip address of wifi via My OSMC. The operation always fails, when Apply is pressed, with the error message that untreated error was identified and see the log.

I have already reinstalled osmc twice or three times but the problem persists. Before, it was working. But due to damage to the USB flash drive from which I ran osmc, I had to reinstall it on a different USB flash drive.

DHCP address alignment works normally. Static IP address I’m trying to align was used before by this system without problem.

The log is uploaded here

Thank you for any advice where the problem could be.


Thanks, we’ll check it out.

Are you trying to set it static to network that you are not connected to yet? I believe their currently exists a limitation in the My OSMC add-on that you can only change the network settings for a wireless connection after it is connected via DHCP.


the static IP address I want to assign I have already used before. It is outside DHCP range. The error message is not related to some fault in IP address format, I believe. I’m changing only the last octet of IP assigned by DHCP server. The message pop up immediately I hit Apply.

I can live without that but on the other hand I would like to know the root cause of this problem :slight_smile:


Are you actively connected to the network your trying to set a static IP on when your trying to make the change? If you look at the thread I linked this seems to be the only way to do this currently through the GUI.