Setting update check for a specific time in my OSMC doesn't work

Hi, I would like to have the update check running at the same time each day on each device. I’ve set to check for updates at 4am but it’s still checking at random times?

Thank you

Thanks for the report. We’ll check it out.

2023-06-10 22:00:39.537 T:4868     info <general>: Disabled debug logging due to GUI setting. Level 0.

Hi, can you provide ‘debug’ logs, again? Thx in advance

Depending on the used skin you have to set the settings-level to standard or higher:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue (here: Just wait 5 minutes after mediacenter start)

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

If possible, could you also provide the link of the command

paste-log /home/osmc/.kodi/userdata/addon_data/script.module.osmcsetting.updates/settings.xml

Thanks for replying, I left it running with debug logs enabled, think it’s captured checking at a random time and not checking at 4am as specified.

Output of paste-log /home/osmc/.kodi/userdata/addon_data/script.module.osmcsetting.updates/settings.xml

@jparm Hi John, sorry, but it was really meant to boot the device twice with debug enabled before taking the log. Now, we don’t know the scheduling time of the MyOSMC update which will be logged on start of the mediacenter. But this kodi log starts 6/10/2023 with a long standby time every day.
Thx in advance!

Well this is a bit awkward but after rebooting it’s now doing the checks at 4am, guess I should have done that before posting this thread!

1 Like

@Headroom Thx for the feedback and glad this could be sorted out. Have fun with the Vero.