Shadertoy visualiser too fast

For some reason Shadertoy seems to be reacting to music I play too fast on my Vero 4K+, compared to on other devices I have. This occurs on whatever the currently selected preset is. Once the issue has started it remains when skipping tracks.

It seemingly can affect all tracks and can happen with one track one day and not the next, I am so far at a loss at how to replicate it.

It seems you can’t uninstall Shadertoy from the addons menu but I have reset it to default.

Has anyone encountered this before and traced it to a particular setting before I get some logs to see what’s going on?

FYI I’m running the GUI at 1920x1080p (2D) at 60 Hz.

Forgot to add I’m on latest August 2023.08.01 version with Vero 4K+ connected via HDMI direct to TV.

Any thoughts?

Is this only a recent issue? Have you used it before without a problem?


Hi Sam,

I’m not sure exactly when this issue started but I’m pretty sure it used to be OK on my Vero. It’s possible it could have started after the upgrade to 20.0. If my memory serves me correctly on versions prior to this, Shadertoy wasn’t included and had to be installed separately from a different repo. I know my currently installed version is the latest but is there a way to uninstall and reinstall it?

There isn’t a trivial way to uninstall and reinstall but I could help you with copying from another Vero (provided Kodi version is the same) if that helps

Sure, I’d be up for giving that a try as using my Vero more and more for music playback these days and shadertoy is my goto visualiser.

Okay - do you have a Vero system where it works as expected?

Aside from this issue and a niggly audio codec related one where sometimes the sound initially doesn’t play out of the correct speakers, everything on Vero 4K+ is fine.

Trying to reproduce your issue with a Vero4k+, I noticed that the visualization Shadertoy stays active even if you deactivate the add-on in the settings.

Can you switch the visualization to None and then back to Shadertoy?

  1. start playing a music track
  2. go to the music fullscreen menu
  3. there click on the visualization symbol on the right bottom (see picture attached)
  4. switch the visualization to None and later back to Shadertoy

Does this change anything?

Thanks Jim, pretty sure I tried that when originally trying to diagnose this, but done it again and will monitor things. Possibly worth mentioning that I am using Estuary skin.

Spent now 2 hours trying to reproduce this with Estuary in place and varied audio and video settings on a 4k+ but I’m not successful.
Depending on how long you need to reproduce the issue, it makes sense to take logs which at least could help to understand your settings and other circumstances.
If it requires several days to reproduce the issue, the logs might be too large. Nevertheless, here some instructions how to collect the data.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

An additional note with the date and time, when you detected the issue, is also helpful.

I got my Vero V back, try to install Shadertoy again, but I see no option to install or select any visualisation, any know why?

You don’t need to install them, they are already there. You probably just need to enable it.

Indeed, needed to go into My Addons for any visualisations to see :man_facepalming:

Apologies for the delay in getting more info on this.

Before I grab logs would it make any sense to you if I had managed to narrow it down to playing 48,000khz MP3 files which cause Shadertoy (or possibly I think any visualiser) to run fast?

I’ve tried the exact same file from the same library share on my PC running regular Kodi and my Vero V running Dec '23 OSMC. It is ONLY an issue on my Vero 4K+. 41,000khz MP3 files play with expected results. I have reinstalled latest OSMC and problem persists.

Please let me know if you still require logs and I’ll try and get some up this week.


Confirmed this is also happening with other visualisers.

Installed Spectrum on the affected Vero 4K+ and my PC running Kodi.

Played same 48,000khz, 320CBR, MP3 file from same network share and the coloured bars on the Vero were definitely moving more quickly than on the PC.

I’ve asked Sarbes (Team Kodi) to have a look at this and have shipped him a Vero V. My understanding is that the Vero V is also affected.

Thanks Sam, I appreciate you getting this looked into.

In my own testing the Vero V seems to be fine playing 48,000khz tracks but I’ll see if I have anything else I can throw at it and report back any findings.

One key difference between my Veros is that the V has passthru enabled but the 4K+ does not. Are any settings related to this likely to be affecting things do you think?

I doubt it – but try it and see…

Tried it on V playing 48K MP3 with passthru enabled and disabled. No change for me, visualiser worked as expected.