Shared storage of media info, watched (etc) for multiple Vero4k+

Well, if you are unable to access network filesystems from your NAS onto the Vero/Media player - screams at: Get my networking and firewalling right.
From experience, when things like these don’t work, it’s the network/security settings of the NAS/Provider.

Next step is optional export of library. Skipping this. I will simply allow it to be re-built.

Next step is advancedsettings.xml

Instructions are:

Create (or add to, if you already have one) an advancedsettings.xml file:

  1. Open up a plain text editor […NOTEPAD ??..]
  2. Copy and paste the text from the right-hand box into a new text document
  3. Replace the two instances of ***.***.***.*** with local network IP address of your MySQL > server. If you installed MySQL on a Windows machine, do not use its NetBIOS name, as not all devices may be able to resolve them.
  4. Save the file as advancedsettings.xml

Copy this advancedsettings.xml file you just created to the userdata folder of every Kodi install you want to sync with.

I don’t know how to do that.
Can this be done from a Windows PC?
Where is the userdata folder on the Vero 4k+ ?

Wiki states several options including:

Linux ~/.kodi/userdata/
LibreELEC/OpenELEC /storage/.kodi/userdata/

In addition wiki also states:

advancedsettings.xml - A user can create this file in their UserData folder. The file can contain additional settings and pre-defined values for the settings available in the GUI (thus removing them from the GUI settings screens). Useful for advanced users and for installers.

But I would rather NOT remove anything from any GUI screen ?!

I migrated to the Vero 4k from WDTV, and used the same NAS then as now. Had shared media library, pause & resume, the works. Never had trouble with the WDTV, nor this much complexity.

You have to understand, most people are not programmers and do not want to “SSH anything”.

Honestly, a post like yours is not helpful. Please do not troll this thread. Thanks.

The first thing to check if the layout changes (as you just stated), is to make sure there is not any firewall in between, a programmable switch, or any other device that would prevent any NFS/SMB requests to go through).
In other terms, you have configured your NAS to eventually only allow the IP from the WDTV (This is section security/firewalling/access rights), preventing the Vero device from accessing the shared folders.
But there are so many different possibilities in configuring something wrong…

@Smurphy as I mentioned I have already opened up access as wide as I know how, to the shared folders on the QNAP NAS where media is stored. As follows:




Microsoft Networking

Other possibly relevant tidbits

  • Cannot “see” any of the Vero4k+ devices from Windows File Explorer → Network
  • From the Vero 4k+, cannot set up backup of its configuration to any folder on itself (cannot make new folder; not permitted to select existing folder; error messages about access or something)


General network information:

Cable modem (router bridged) → Unifi USG —> Unifi switch

  • NAS connected via ethernet to switch
  • each Vero 4k+ connected via ethernet to switch

Model of QNAP: TS-121 running firmware (build 2018-10-29).


My Windows PC(s) are connected to the networking workgroup called WORKGROUP:


This article: File sharing with a NAS, media server, windows share or other device discusses that SMB cannot be used with file/folder browsing unless you take a security risk and use SMB1.

This article: Transferring and editing files is perhaps what I need to do to create and copy/paste the advancedsettings.xml … ? It also states:

Some of these methods will work out-of-the-box (Provided you have not disabled SSH) but some will require additional features to be installed on your OSMC device like the Samba (SMB) server or the FTP server.

But frustratingly does not have a link for how to do that. Found some instructions here which state:

  • Select MyOsmc, and then look for the shopping trolley icon.
  • Pick Samba (smb) Server, and then go to the Install button - whereupon it should install

…and I noticed ‘FTP server’ was not installed either so I did that too.


Relevant NFS & MSFT Networking settings on my NAS:


Having installed FTP and SMB servers on all 3 Vero4K+ devices, I then renamed each one under Settings → Services → General → Device name , to have a unique name Vero4Kx__ where the blank is either ‘B’, ‘K’, or ‘T’ based on which room each one is in. Then rebooted each one.

After that, from Windows File Explorer, by typing in " \\Vero4Kx__ " I am able to see the following on all 3:


…where the “Backup_B” directory was created by me just now, to test write access to the “osmc” folder. The 4 other folders are all blank.

I have not learned how to access any other folders, like the “userdata” folder mentioned in the wiki ( ~/.kodi/userdata/). Obviously it is a system folder that is somehow hidden.

After multiple trial & errors, this worked: \\Vero4KxK\osmc\.kodi\userdata and notice you need to delete the tilde and the slash next to it.


Decided to try “Export Library” after all, but good thing I don’t care much about it because the import part (done a little later) didn’t work. You are not told during the export step where it is exporting to, so you have to guess or hunt during the import step. It does state in the WIKI that it puts “nfo” files next to each video. But during import, it asks you to browse somewhere, and there’s no mention of the nfo files during the import wizard, for example to simply scan for those nfo files. Skipped it.

Created advancedsettings.xml via JEdit text editor – cause I read online it is good at making a “clean” text file – and copied it to first Vero4K. Reboot. As expected, everything is “gone”.

Chronologically, the attempt to import the library occurred next.

Decided to give NFS a try since I had installed & enabled the NFS server. As mentioned, last time I tried NFS was quite a while back on a previous Vero4k (non-plus) and I probably did not have the Vero’s NFS server installed and enabled back then. Why would I? As I recall, when you try to browse using NFS the interface does not warn you that you need to install and run that server.

Anyways, I removed all video and music sources (previously added via ZeroConfig) and during that process told it to clean up the library(ies). Then I re-added each source back via NFS – yep it worked. Then during the Add process, told it to rebuild the library. That part took a long while, especially for the Music Library.

Having to sit & wait for the libraries to update, I notice in Windows File Explorer that the time-stamp for the Textures13.db is updating – and later in the wiki it mentions copying this file to the other Vero4K devices. Okee dokee. But there are two other large files (MyMusic###.db and MyVideos###.db) the timestamp for which is static and is getting older. I am wondering if those files can be safely deleted now, because a new version of it is stored somewhere on the NAS ??

Do not delete the MyMusic and MyVideos files, those are your music and video databases.

OK, so they are not stored centrally on the NAS? Then I guess I’m confused about how this is working.

If one device updates the library in its (local) .kodi\userdata\Database folder, then how do the other devices know that their own (local) libraries need to be updated? Are the *.db files somehow synced but each maintains its own (duplicate) copy?

And if they are merely synced copies of each other, then why does the WIKI state you should copy & paste the Textures13.db file but not the others?

How is the “watched” state maintained, and also the information about paused or stopped at timestamp hh:mm:ss ?

Did you setup a mysql database? If you did then those files are not used. What does your advancedsettings.xml file look like?

cat ~/.kodi/userdata/advancedsettings.xml

Up in this post I mentioned that I had gotten mySQL up and running on my QNAP NAS, and used myPHPadmin to create the ‘kodi’ user.

Ok, sorry I missed that. I’d like to see what you have in your advancedsettings.xml, then I will know for sure if it’s safe to remove the My*.db files.

I started out with advancedsettings.xml as instructed in the mySQL Kodi wiki.

Perhaps the system has since made changes to it, so I attempted to copy & paste it here but this forum doesn’t like all the < and > signs in the text. How do I get it to accept it as-is and not re-interpret any of the text?


Use the preformatted tag by clicking </> above the text input box or indent with 4 spaces.

Good, you are are truly using the MySQL database. So the My*.db files are no longer needed!


On the other hand, I assume that each device still does need its own Textures13.db … right?

Yes they do unfortunately. (Well, there are ways to share Textures13, but I’ve found them unreliable. So for now I’d recommend not trying to share it)

Well, local storage of images, even thumbnails, probably yields much faster performance on the device. In any case, I like reliable. Thanks much for the advice.

I haven’t yet tested the brand-new-to-me shared library including update of watched state, and pause/resume from anywhere. I’m still waiting for the music library to finish rebuilding itself on the primary Vero 4k. The scroll bar is only 25% about ~3 hours so it may be tomorrow before I will feel OK about rebooting the other 2 devices and testing all this.

Assuming it works and I’m done, the whole project took about 10 solid hours over yesterday evening and today.