Sharing library with Windows devices

My primary setup consists of a pair of Vero4K sharing content from a QNAP NAS via FSTAB mounted NFS and MySQL on the NAS for the shared library. This all works fine (within limits).

I have been looking at adding a Windows 10 based device into the mix as a KODI client, however I’ve come to a bit of a got-ya around the naming of the media in the library. NAS provides both NFS and SAMBA access to the same content locations.

As the library has obviosuly been populated from the linux side, the library has content names such as /mnt/sharedmedia/… for content hosted on the NAS. I thought I could use advancedsettings pathsubstitution on Windows to massage these to smb:\NAS1\SharedMeda… however I can’t seem to find a combination of substitution that works.

Is there a best practice for this situation, or any ideas as to where I’m going wrong please?

All the best,
Mark W.

Yes, always use one machine to scan media into the library and on all other machines use path substitution

If you want to use a shared mysql database for several Kodi clients that use different methods to access the shared media (e.g. a mix of SMB, NFS and/or fstab based access) you could use the path substitution function of Kodi to align the access. But watch out it is important that you only add new files to the database from a single client otherwise you would need to have different path substitutions on each client.
Please see Path substitution - Official Kodi Wiki for details.

Thanks very much for the input. I’d already had a look at the kodi wiki, however I can’t see to fathom an subsitution that will turn my Linux /mnt/… paths into something acceptable to KODI on windows. I thought I had it by adding “smb:” to the start of the NAS address, but according to the KOID log on Windows the video player can’t open the file.

I currently have the following, however this definitely doesn’t work:-

<pathsubstitution>
  <substitute>
    <from>/mnt/sharedmedia/</from>
    <to>smb://NAS3/SharedMedia/</to>
  </substitute>
</pathsubstitution>

Can anyone comment who’s actually had this working (Linux created library being accessed from Windows) please?

Sorry, XML mangled in paste.

That’s:

from: /mnt/sharedmedia/
to: smb://NAS3/SharedMedia/

You have to use the </> button in the editor to make code readable on the forum. I fixed the first for you.

Is that your entire advancedsettings.xml? It should also be nested in advancedsettings flags like this:

   <advancedsettings>
      <pathsubstitution>
        <substitute>
          <from>/mnt/sharedmedia/</from>
          <to>smb://NAS3/SharedMedia/</to>
        </substitute>
      </pathsubstitution>
    </advancedsettings>

Sorry, relative forum newbie. Yes, I have this embedded in an advanced settings file including cache settings and MySQL params OK.

I beleive I have stumbled on the answer by “trying stuff”. Substituting the IP address for the NAS name seems to work.

Yes, that’s a much better solution. Glad you are up and running now!

I’m running a mixed setup (4x Pi/Osmc + 3x Windows 10 Laptop).

The windows clients also use nfs as access method. I just copy the same advanced settings file to every installation.