Sharing videos

Using the vero 4k, with kodi as the main display unit, I have an intel NUC, that acts as a server, it has my tv and movies stored on an external USB drive.
From the vero, I have tried to add the NUC as a source, and select add videos, it goes well until the vero attempts to scan the dir with movies/tv shows, says the network is not connected, but it is.
The ip of the NUC,, the mount point is /mnt/medialibrary/tv and /movies.
From my desktop I am able to ssh in or use dolphin to access the NUC. I have tried ftps and ftp, and installing minidlna server,
Any suggestions?

What does your /etc/fstab and ~/.kodi/userdata/sources.xml look like?

This is on the NUC

tv shows

UUID=c38e5857-cf48-41f4-8f46-60498c458dc0 /mnt/medialibrary/tv ext3 defaults,errors=remount-ro 0 1


UUID=e5dc225b-bdf9-49c0-927c-a86fc6aba8fe /mnt/medialibrary/movies ext3 defaults,errors=remount-ro 0 1

link to ~/.kodi/userdata/sources.xml

Your sources are wrong:

<path pathversion="1"></path>

should be

<path pathversion="1">/mnt/medialibrary/tv</path>

changed it, still says couldn’t connect

now saying path not found or invalid

Did you edit the file manually, or change it in Kodi? If you edited the file manually you need to stop kodi, edit the file and then start Kodi. You also need to fix the path on the sftp source (or just remove it).

sudo systemctl stop mediacenter
edit the file
sudo systemctl start mediacenter

It’s probably best to just do it using Kodi however.

If that still does not work, we will need logs.

edited both, within kodi and nano, rebooting also
I’m guessing debug log

<path pathversion="1"></path>

Your source is still wrong. It needs to be /mnt/medialibrary/tv/

EDIT: also, you do not have the drive mounted using fstab. It’s mounted at: /media/B942-551D, so the source really should be /media/B942-551D/tv

ok, edit the file, again, reboot, the error:
Couldn’t retrieve directory information

ALSO reread the first post, the usbdrive is MOUNTED on THE NUC!

Good luck, I’m done trying to help. You initial post was very confusing.

1 Like

also the post showing the /etc/fstab explains its on the NUC!

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Can you add the sftp source in the FileManager under Settings? Then you can easily add it by name when adding as a video source.

yes, tried that, only thing different is I get the spinning snake, then says couldn’t connect to remote server. I can ssh into the vero and sftp to the nuc, so something’s not making sense

Are you using a network sharing system on the NUC, such as NFS or SMB?

No sharing system


It will need one of these, if you want to share from the NUC. What OS is the NUC running, I’m guessing its a version of ubuntu?

This is probably one of the easiest ways to share videos to kodi, how far did you get?

Alternatively it may be easier to attach the external usb drive to the vero4k, if you then install the samba server from the MyOSMC store; it should automatically share the external drive and then you can share this with the nuc and any other devices that need it.

On the vero4k itself, you can just add the external drive as a video source.

Thanks Tom.