Should my new Vero 4K see my Windows network?

Hi, I’m Cleo and I’ve just bought a new Vero 4K.

It gets smashing reviews and I’m really excited about it, but I’m not sure how to connect it to my home network where my videos and photos are stored.

(So I can see them on my TV).

I know a teeny bit about Windows (7) but absolutely nothing about the Vero. Does it run Windows, too? Or is it another system?

Sorry for the dumb questions :sob:

Start here File sharing with a NAS, media server, windows share or other device

Get back to us if you get stuck.

Graham, thank you so much for your tip! I’ll do that (or try anyway :-))

By the way, I just noticed something has changed with the Vero since yesterday when I brought it home: now I can see it (the Vero) from my desktop and my laptop computers.

I even managed to copy a movie from my laptop into its Movie folder! Wow!

But I still can’t see my computers from the Vero when it’s connected to my TV :thinking:.

Hi,

Congratulations on the purchase of your Vero 4K.

It sounds like you installed SMB Server from the App Store which would give you this functionality.

Automatically ‘seeing’ Windows shares as you’ve described is a mostly deprecated feature because Microsoft removed support for this for security reasons after the WannaCry attacks.

You can indeed restore this functionality however if you wish to do so. This is highlighted under the ‘OSMC as a client’ section in the link that Graham provided. You would make those changes on your Windows computer, then go to Settings -> Services -> SMB Client and set to Version SMBv1. You can then reboot devices and should be able to access shares.

Have you shared your hard drive on your Windows PC already (i.e. is it available to other devices)?

P.S: you seem to already have a forum account with us. If you’ve lost access to that, let me know and I can help you re-gain access.

Sam

Hello Sam, thank you for your lovely welcome, everyone is very friendly here, that’s so nice!

I think you are right about the Samba Server, I just saw ‘update’ and clicked go. I should have been more careful but I think I was feeling clever!

I followed Grahame’s links but only got as far at the bits that said Kodi will only run on SMB one.

Which is a shame because I don’t have it on my computer but it does have the no.2 version.

(I didn’t know this! - one of the chaps at work looked at my laptop and told me)

So is there another way of joining my Vero to Windows (it’s 7 if that makes a difference)?

Oh, and Windows is fully shared. My friend said with “Everyone”. Does that make sense?

Thank you so much for your help :slight_smile:
Cleo

First, let me set the scene.

Not quite. Kodi runs any flavour of SMB but to enable browsing to another computer and its shares, you have to force kodi to use only SMB1 and enable SMB1 on Windows.

You should be able to enable SMB1 using the instructions here: Enable or Disable SMB1 File Sharing Protocol in Windows | Tutorials But the only reason you need SMB1 is to enable browsing. You can set up the share without browsing (see below).

No, it doesn’t make sense, but it’s MS who are confusing things. It is no longer possible to open up a Windows share to anyone (as anonymous/guest). ‘Everyone’ means anyone with a login (and password) on your computer.

The last bit you (may) need to know is that the way Windows machine names are shared on the network is flakey.

So try this: lets say your laptop is called LAPTOP and you have a shared folder on it called SHARE. Your username on it is cleo and your password is cleopass. Then in Kodi, go Music->Files->Add Music, click where it says <None> and type

smb://cleo:cleopass@LAPTOP/SHARE

That should work, whatever flavour of SMB is being used. If it doesn’t, the next thing to try is to find the IP address of the laptop (say it’s 192.168.1.3) and use this

smb://cleo:cleopass@192.168.1.3/SHARE

If you do it that way, you should make sure the laptop has a fixed IP address. Come back if you don’t know how to do that.

If it still doesn’t work, we will need logs.

1 Like

Graham, you’re wonderful! Your suggestion worked perfectly!

I used the first option, the one with LAPTOP and SHARE and it worked first time.

And somewhere in KODI - I’m sure I’ll never be able to find my way there again :slight_smile: - I found something that said 'SMB3, so the comment I saw on the KODI site about it not being able to handle anything over SMB1 was obviously wrong.

Oh, I’m so relieved! I thought I might not be able to do this but with your excellent help, I managed. Hoorah!

Thank you, thank you, thank you!
Much aroha!
Cleo :kissing_heart: