Show files but can’t play videos

Hi everyone,
Is my first post requesting help but i really can’t solve by myself.
I was using kodi with osmc and everything was smooth, now , after a period of inactivity, when i try to play a movie on a WD Mybook connected via samba video doesn’t start…i already made a fresh reinstall, no addons, it see all video in the folder via samba address but when i click on movie it load a bit and go back on home screen. Please help me thanks
I have a raspberry pi3+ with latest version of osmc

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

So the log should be here:

Additional information, i can smoothly play videos from WD MyCloud nas connected via network workgroup. I just can’t play anything on WD Mybook connected to my mac and reached via samba. I can see all files and covers but at the moment i play video go back to home screen

Have you tried playing the same file on your MyBook on your Mac to see if the drive is the issue?

Yes of course. Everything works fine individually. I can play everything from every hdd on the network, except from mubook via samba… strange thing is that i can move and see everything in the mybook browsing from kodi. I also tried to change different combination of video acceleration settingbut unuseful


Whats max & min protocol set to under:

Settings - Services - SMB Client

Thanks Tom.

Minimum None
Maximum SMBv3


Try setting Minimum to SMBv2 or 3. If that works, you will need to double check it still works with your WD MyCloud.

Thanks Tom.

Nothing. I tried also with minimum smbV1 but doesn’t work, i stead continue working with MyCloud.
The fact that samba clint workgroup is named WORKGROUP is not a matter? Wins server is

Thanks in advance

Seems Solved! I had to set bot minimum and maximum at smbV1… someone knows why? Maybe mybook is a bit old? Or mac works with old version of smb?
Anyway thanks a lot!

1 Like