Simple IP TV doesn't work


I installed OSMC on a reaspberry pi B+ ( RC2) ,simple IP tv TV doesn’t work
I added my m3u list that works on the old XBMC, it starts loading a chanel I select from the list for 2 seconds then stops and nothing is displayed.

Please help


Does the channel use mpg2, and have you a licence for the codec.

how can I know if the channel use mpg2?
no I don’t have a codec
here is one of the chanels url:

Well, I can confirm that it didn’t work for me either in Simple IPTV Client. Then again, I tried it in VLC and got nothing. I’m not sure what I could test with that would actually show me this is a working stream?

please who ever has a codec tries this:

don’t actually know if it’s a codec problem or not
for me it works in VLC, but not in osmc…
can you give me a link to one of working ones so I can try it?


Opening in VLC I get StreamNotFound. Could it be that this is only accessible from within your provider network?

no impossible, it’s a server in germany and I m in sweden.
are you using a m3u file to run it?

same result, using m3u with the information you have provided or giving VLC just your URL via Open Network Stream

no chance : (
how can I know if the chanel needs codec?

Here’s a channel that works fine in Simple IPTV and VLC.

#EXTINF:0 tvg-name="Fresh Tv Music" audio-track="" tvg-logo="MUSIC.png" group-title="MUSIC", Fresh Tv Music

this works. but ,not mine…
does this needs codec? IF NOT, maybe mine needs
But is codec installed by default in old XBMC?
because there my chanels works fine
maybe something is wrong with OSMC then

I don’t think OSMC has much to do with it. Everything’s being handled by Kodi & Simple IPTV PVR Client.