Simplecom RT200 or a better remore for the Vero 4K+

Hey all
I bought a Vero 4K+ and after numerous attempts at trying to use the remote that it came with, I have given up due to it’s lack of functionality and it’s unreliability. It keeps dropping out if it connect in the first place. I have to unplug the box and plug it back in to get it to register the remote and even that does not work most of the time. Have reset the OS and nothing seems to fix the issue.

Anyway, I saw the Simplecom RT200 and was wondering if anyone else had use one like it or better. The keyboard on the back looks handy but I really need something that works.

Some feedback and insight would be greatly appreciated.

Peace and props.

The remote shouldn’t be dropping out.

Try another battery, and try re-pairing it by holding Home and OK.

If you still have issues, then more information is needed, such as whether you see a blue light when no press is registered and if you see a short flash or a long one


All keys that are transmitted as standard keyboard key will work.

Hi Sam
Thanks for responding and for your suggestion. I powered up the box (by unplugging it and then plugging it in as the remote was not working). After it powered up again, the remote was still not working so I unplugged the USB dongle and then plugged it back in (front USB but have also tried the back one) and then the remote started working every third or fourth button press. I tried the Home and OK which you suggested and for some reason stopped the remote working all together. Maybe rebooting it again may make it start working again. As for the blue light, I cannot find any blue light anywhere. The Vero 4K+ has a red cross illuminated on the front when it is switched off and then it turns off when it the Vero 4K+ is on.
Is that enough information? I’m hoping I have not missed anything obvious.


There is a blue light on the front of the OSMC remote. That is what Sam was referring to.

Hi Fzinken.
Thanks for the response. So you are saying that the front button functions all work and the keyboard does as well? Just thought I would clarify.


Hi Bmillham
Thanks for letting me know where the light is. I took a closer look and finally found it hidden under a panel. I was expecting it to be lit up as in on the surface but at least I have found it. Yes. The light illuminates every time I press a button. I pressed it a number of times to test the duration and most of the time, it is a short pulse of light but i did notice probably every fourth or fifth seems to last for maybe a quarter of a second longer.
Hope that helps.


Do as Sam suggested and try a new battery. Sometimes if you are in an area with lots of RF interference (like an apartment with a lot of WiFi routers) the remote will start frequency hopping. That can drain the battery. If you try a new battery and do the re-pairing again it hopefully will find a better channel and stop hopping and give you a reliable signal.

Well as I said it depends how they are transmitted. Eg. I have a Rii Mini Remote on wich all keys of the Keyboard are working while some of the keys on the back are not working, reason for that is they are not transmitted via the 2.4 GHz dongle but by IR. So for them to work you would need to configure the IR receiver on the Vero.

So it depends how that specific remote is transmitting all keys.

Hi BMillham.
Thanks for the suggestions. Also a thank you for an explanation about the frequency/channel jumping. IT is actually within a metre of a router so that could be causing some issues. I did not consider it but now you have mentioned it…
As for the battery, I had changed it before but luckily I had another CR2032 battery so I changed it. I put it in and then went to the box and pressed a button on the remote and nothing happened. When I did the Home and OK button press together, the blue light went on and stayed on for almost a minute solid. It did not register with the box so I unplugged it and plugged it back in. As soon as it came back up, I pressed the up and down (it was on the Video side menu) and every fourth or fifth button press worked. As soon as I get can turn the router off (people are using it at the moment), I will try the remote again and see if it workes better which will tell me it is the router and I need to work out how to change the frequency.

thanks again. Really appreciate the insight.


Okay. Thanks for that. I was actually going to ask how to configure the IR Receiver. I will take a look shortly and see where to do it in the OS. I am new to the OSMC/Kodi envori. I used to use XBMC but it mostly worked out of the box for what I needed so I did not have to configure it as much.
Oh well, I’m glad I like learning and a change thrown in.

I would not think that the local router would be much of an issue. The real problem normally is lots of other routers in the area. But is is definitely worth a try if you can turn it off and see if that helps.