Single USB port failure on Pi?

Hi all,

My OSMC setup on the Pi3 has been working pretty well for several weeks now. I watch Live and recorded TV programs that are stored on my backend computer and streamed wirelessly to the Pi in another room. I have the OSMC wifi dongle installed and it is connected at 5G.

Last night, I couldn’t watch Live TV because of significant buffering that I had not experienced at all in the past. I watched a recorded TV program and that worked ok for awhile and then I started getting buffering. After about an hour, I could not get Live TV at all and could also not “connect” to any of my recorded TV programs. That is, gradually, over about an hour or so, my viewing experience deteriorated to a point where my setup was unwatchable.

I noticed that the blue light on my wifi dongle was glowing but not blinking, so I reckoned something might be wrong with it. As a quick test, I plugged it into a different USB port on the Pi and voila!, all was well again.

This suggests to me that the port I had plugged the dongle in failed. I did a search here and on the internet and found numerous references to all USB ports failing but nothing related to a single port. Have others experienced this problem? Is there an issue related to the USB dongle that causes this?

Right now, I’m just interested in others’ experiences. If this happens again, I’ll post logs and seek further assistance.

Thanks for any help.

Did you try another device in the port? Or move the dongle back? I could have just been that the dongle just needed a reset.

I just plugged another device into the vacated port and it worked fine. I guess I just needed to reset the dongle. All is well right now.