Skin changes lost after a reboot

mmmmmmmm… tomorrow i try to backup some files from pi2 directly to my pc and see what’s append…

I thinks when append i can simply restore saved setting and restart kodi using also systemctl restart mediacenter…

You can – but it’s probably better for us to fix this.
If you keep restoring the file, then the issue will never be fixed.

yeah but how i can help you or i can provide to you for help to investigate about this little trouble ?
I can’t reproduce this at every reboot but for me it’s append every x days in a totally random…

I’m getting this bug too. Many of my settings (most of them skin related) get wiped about once a week.

After reading this thread I activated the debug mode in the GUI settings, and was lucky enough to get my settings wiped after a reboot (well, not really lucky, it took me more than 20 reboots to reproduce it).

Anyway, I went to check my logs before uploading them, and found something very similar to what bonera posted (i.e. not debug logs). I guess these lines (which come after Kodi says it can’t load my settings and decides to create a new profile) are the ones to blame:

Disabled debug logging due to GUI setting. Level 0.
Log level changed to “LOG_LEVEL_NORMAL”

So, if I’m understandig it correctly, the fact that my GUI settings get lost is preventing me from capturing debug logs. Any idea how to go around this?

You could just pass --debug. But the issue is now resolved and I will post more information shortly.

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Thanks to @bmillham for testing.

Thank you so much for the quick work, Sam.

When I run dist-upgrade, the only packages it wants to update are:
eject libsmbclient libwbclient0 samba-common samba-libs

If I disable your devel repo, it wants to update exactly the same 5 packages, so I’m not sure I would be installing your fix.

I posted this prematurely last night, expecting the builds to succeed.
Unfortunately they didn’t, because the Team Kodi mirrors website used to host files is down as part of the April Fool’s prank. So we must wait…

Following… :slight_smile:

Unfortunately, @sam_nazarko will be away for a few days. I’m sure he will publish this fix ASAP.

I cannot install the updates yet but I noticed that the devel repo has been updated. I assume that the patch has been included?

EDIT: installed the new OSMC version. Will test later.

Hello, All! 1st post and 1st things 1st. Sam, /bow. OSMC is amazing very impressed!

Today this same problem happened to me as well. I tried a reboot from the web UI as pandoki was playing. I run a USB sound card as well. Both the skin and sound card were set back to default. I’ve only noticed this on a reboot. Every other time I’ve tried shutting down, pulling power, and reconnecting power its worked flawlessly. Admittedly, I’m pretty noobish when it comes to all this but I’m happy to help however I can.

i disabled debug logs yesterday in all 5 rpi3 i have and today on 4 of them i had a complete reset of everything. damn.

I also get the kodi cannot connect to json-rpc message on all of them.

I just disabled logs yesterday ffs

and after another restart in all of them i got skin settings reset as well. #R@#R@#

According to Sam the fix is currently only ready for the Vero3: Vero 4K - settings reseted after reboot - #14 by sam_nazarko

I guess that I was just lucky that my Pi2’s settings survived two reboots.

It’s available for Vero 1, Vero 2, Vero 4K, PC (internal testing) and Apple TV. RBP requires more changes due to some updates in userland, but I will get it built soon.

1 Like

It’s ready for Raspberry Pi now. Please let me know if this issue is resolved.

Sam

Thanks for the efforts @sam_nazarko. Will report if something goes wrong

I just installed it (remotely) via SSH but the apt-get dist-upgrade command seems to run without any installing anything:

osmc@osmc-keuken:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following package was automatically installed and is no longer required:
libjasper1
Use ‘apt-get autoremove’ to remove it.
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Maybe it’s because I did a manual upgrade earlier this morning via the GUI?

Yes. It’s been in the repository for a few hours.

I will do a couple of reboots and hopefully the problem is resolved. I guess this will take some time to be 100% sure as my last reboots without the fix also kept the menu settings.

thanks for all the work on fixing this!