Slideshow is crashing OSMC

I am running OSMC 4.1.5-1-osmc on a Raspberry Pi 2 Model B. I am using the OSMC to run a slideshow of family photos and videos. It will run for different intervals (the last crash, it ran for 1.5 hours) and then the screen stops displaying photos and videos. I have enabled debug and even though the slideshow stops, the screen continues to display the debug text with updates. I am able to SSH into the OS without any issue. My only recourse each time is to reboot the Pi. I am at a loss if this is an OS issue or a hardware issue. Any help would be greatly appreciated. Logs are linked below. Thank you.

I think I am experiencing the same issue. Will provide logs soon when I can get access to the device.

Could you try running bcmstat while the slideshow is running.
Use the “leak detection” option from the github instructions.


I am running ./bcmstat,sh Dd10 to an output file right now. I should also note that I have a second identical Raspberry Pi and I tested this slideshow failure out on that one and it experienced the same failure. I will post the output file as soon as the slideshow fails. Thanks.

Here is the link to the bcmstat data. I ran the command “./ Dd10” during my slideshow. The slideshow crashed after roughly 30 minutes. Thanks.

Doesn’t look like a memory leak.

Possibly you have a jpeg that is provoking the crash.
Can you try splitting the sideshow folder into two and see if only one of the halves causes the crash?

The slideshow I am running is a combination of pictures and videos. I am going to try the slideshow with just the jpegs and see if it crashes. If it does, I will start cutting the number of pictures in half to see what happens. I will post back shortly.

According to uname I have “vero 4.1.12-11-osmc”, but recently I did upgrade to the December release of OSMC. Using either local pictures, SMB or DLNA, if I start a slideshow, the first picture is fine, then the screen goes blank, followed by an involuntary reboot. Other things of note are that I’m running a different skin (not the OSMC default) and that the slideshow is on random, not sequential. I’ve done a MyOSMC log upload in case that helps: Does anyone have any idea what could be causing this?

jamieholland, I cannot answer your question but I can tell you that now I am running a slideshow only against jpegs and not jpegs, mp4s, and movs, I have been running for over 6 hours now without any issue. I believe there is a problem if you try to run different types of files from the OSMC Picture slideshow; that is, if you are running the slideshow from Pictures, you shouldn’t have mov or mp4 files mixed in with jpeg files. I am going to see what happens when I run mov and mp4 files from OSMC Videos. Thanks.

Sorry for the late reply. My topic was a new one, which was merged then later split.
Mine was only jpeg files, so we must have different issues.

Same issue here.
OSMC on Raspberry Pi 3, OSMC 2016.02-4.
Running a Slideshow with 4 JPEG Files an 1 h.264 Video from USB drive with the SlideShow command.

It works perfekt for different timespans. 30Mins, 2 hours, 4 hours. Today 8 hours.
Suddenly the screen went black and i have no control with the keyboard. Looks like osmc crashes.
In the debug output (OSD) i see normal CPU load and memory usage. I can SSH to the Pi. Tried to send kodi commands to restart the show or stop. No reponse.
I tried with other Images and Video files. This has no effect.

It is almost certainly a corrupt image file.

  • Take half of the images out of the picture folder.
  • See if this stops the crashing
  • If it does, copy half of them back in
  • If it does not, copy half of the remainder out as well
  • Repeat until you isolate the bad image.

For shure. I tried that.
The loop runs well for hours with this 5 Files and in the past with other files. I also tried with 2 Files.

I made testfiles with Fireworks and Photoshop. Tried png and jpg. All the same.

After hours (2 or 4 or today 8) it chrashes.

I am going to put all the files and debug log on my ftp server tomorrow. Hope someone can help…

Please do not ftp. Pointless for us to download logs to read once. Simply provide the URL retuned from grab-logs -A

I have the same issue. I’m running on OSMC 2016.04-02
Is there any fix for this? Mine OSMC is also crashing when scanning for media info when opening some picture folders.
My Picture library is mounted on external drive /media/Pictures