Slow 1080p playback

Hi all,

I have recently upgraded to the RaspberryPi 2. I have installed the latest OSMC for RP2 and have everything setup to access my windows 7 share.

When i play 1080p video from my windows 7 machine playback is very choppy or it does not work at all.

Currently using Power line networking within the house as i cannot run cable but i don’t recall having this much trouble with my RP B+ 512mb running rapbmc.

I have tried suggestions in other posts but still no luck.

Any idea on how to improve this or will i have to run cable?

What kind of video file is this? How high is the bitrate? What Codec does it use?

If you wanna make sure the network is not your issue, just copy the video file to a USB Flash drive and connect it directly to your RPI2. If it’s there running fine, guess your notwork is really the issue.

Yes, an obvious cause would be an MPEG-2 or VC-1 file without a codec licence. (Perhaps you did have the licence on the Pi1).

But provide debug log or mediainfo.

I have since played around with a few settings and have it streaming to a level I’m happy with but now when i skip (fast forward) a movie it will pause and buffer for awhile again.

I don’t know what bitrate is of all the movies but they are 1080p rips using MakeMKV (if that helps)

How to i check / get a MPEG-2 or VC-1 codec licence?

I’ll post a debug logo later tonight.

Thanks again

To check whether you have them

vcgencmd codec_enabled MPG2 vcgencmd codec_enabled WVC1

To buy them go here