Slow ethernet iperf3 speeds until reboot

While I do agree that the thread is a little confusing, it can be divided into two very different problems, which I’ll try to detail below. If anyone disagrees with what I say, or thinks that I’ve forgotten something important, please feel free to chip in.

I’ll deal with @floatingkiwi’s problem first. This issue seems to be a randomly occurring slowdown of iperf3 itself and, on the basis of evidence presented so far, is not related to a slowdown of the network itself, nor has it been suggested that the performance of video streaming has been degraded. After the iperf3 slowdown has occurred once, all subsequent runs of iperf3 are also slow until the Vero4k+ is rebooted.

iperf3 figures show that, when the problem occurs, data throughput drops from around 945 Mbps to around 100-200 Mbps. In this case, the ethernet interface has clearly not renegotiated to 100 Mbps.

floatingkiwi has already confirmed that the problem occurs even when the Vero4k+ is directly attached to the same router as the PC running the iperf3 server. From this we can exclude it being down to a network issue per se between the media room and the office PC and we can infer that it’s not an issue with a switch, cable or port on the switch.

I have confirmed, via ifstat, that there is nothing else consuming the ethernet bandwidth on the Vero4k+ when a slowdown occurs. If it had been a congestion issue elsewhere on the network, I don’t see how a reboot of the Vero4k+ would clear the problem.

The iperf3 figures (using the -V flag) suggest that iperf3 itself is the problem (or at least a part of it). When the slowdown occurs, iperf3 uses high CPU and the process seems to become CPU-bound. I have examined the iperf3 source code and the CPU figures shown by iperf3 are for the iperf3 process itself, and are not for the whole operating system.

There seems to be some kind of state change on the Vero4K+ that makes iperf3 run in low-throughput / high-CPU mode. I don’t have a Vero4k+, so can’t investigate this further.

One outstanding test that @floatingkiwi can run is to see if thie issue is confined to iperf3 or if the slowdown, once it occurs, affects other network traffic, eg NFS and/or SMB.

@Ainsley’s problem seems simpler. The Vero4k+ is showing a relatively large number of dropped ethernet packets and the interface is renegotiating from 1 Gbps to 100 Mbps. I’ve asked for a before and after ethtool report and full logs after the renegotiation has occurred. We can take it from there.

I’ve asked ainsley to start another thread so I can continue with my own one and not confuse everyone.

  1. yes all cables were changed.
  2. yes tried diff ports
  3. not possible
    4)I’m not able to test this - no, there shouldn’t be anything else using bandwidth at the time.
  4. unable to test this either.

Nothing else ever seems to be affected by/during this slowdown of the vero.

I know the vero is slowing down because even though streaming isn’t affected, (150 ish mb is enough to stream most files), I can see the ssh service slowing down, and the device takes longer when using things like the netflix app to view content.

In particular, I know exactly when it has slowed down as when ssh’ing in, it takes a second or 2 to ask for teh password, rather than show that text instantly.

So in summary, (and relating to @dillthedog comment above) I know the vero network is indeed slowing down and this isn’t just an iperf3 thing.

Yes you asked for before and after ethtool report.
I did the “before” one, but since then the connection didn’t degrade to a 100 Mbit/s connection, so I did not make the “after” report. I have a guess that the connection only sometimes switches to 100 Mbit/s when I reboot the device. I used to reboot the Vero relatively often, so maybe there actually is no problem that causes the connection do degrade.

To avoid further confusion, just ignore my problem, that maybe isn’t actually one.

No worries. I was expecting you to post all the details after you experienced the problem.

  1. When a slowdown occurs, can you run a dd file copy over the network and compare it with the iperf3 speed?

  2. Sorry to be a stickler for detail, but how do you know that the network is slowing down, other than by using iperf3?

  3. Do you have anything else to add re. my write-up?

Edit: I see you’ve answered point 2, but 150 Mbps is way faster than you need for a responsive SSH session.

I think I’ve seen this. Have you tried pinging the device while speed is affected? Can we see that output? Did you say you had Ubiquiti Unifi gear in the chain somewhere?

I’ll try the dd file copy. I’m very much a linux newbie!

I haven’t got anything to add really to your writeup - all I know is that the vero is slowing down as iperf3 seems to be saying. I can tell from network responsiveness and app response times. THe last of which is odd, because my internal network speed, even though dropping to 150-200 is way faster than my internet connection, which is 100mb.

It is slow right now and still good 1ms (consistent) ping times. <1 to the switch.
No ubiquity stuff in my home system.

Sorry, was a shot in the dark from me, but something rung familiar in my ears :frowning:

I’m gonna need help with this dd file copy thing fellas. I’m assuming of=/dev/null is the directory of my remote server? How do i find this.

I know dos…

Could you elaborate?

ssh’ing in is slower response times when asking for password and performing tasks.
netflix app takes longer to start streaming the same program. Longer to list and download subtitles from the internet.
Viewing local server files and directories takes longer, noticeably.

Nope. It’s a device on your Vero box. Use “as is”.

where is the movie file located? I tried something on the smb file server and no worky.

Is the general screen navigation noticeably slower?

no - only anything related to the network (i.e data transfer).
Although the interface can freeze at times, I can’t correlate the two as being related though.

dd if=\readyshare\usb_storage\tv series\lost in space\ of=/dev/null
bs=1M status=progress
dd: unrecognized operand ‘serieslost’
Try ‘dd --help’ for more information.

I’m not figuring out how to tell it where the file is…

See Configuring fstab based Samba share mounts . Using fstab will probably be easier – and quicker.

wow thats a day of digestion right there… I WILL GET TO IT…:slight_smile:

The thread’s been running since June 2019, so what’s another day or so? :slight_smile:

1 Like