Slow internet performance after latest update


I use speedtest-cli to check my connection regularly on my pi2 running OSMC, it works pretty well allthough the latency/ping is about 30ms more than on my windows laptop. (why?)

I recently set up a rpi3 with OSMC and tried the speedtest-cli script again, and noticed a huge delay (2600ms etc) and very slow performance.

Some troubleshooting to cross out network issues, and ensure latency and performance work well between computers in my network, I updated my pi2 to the latest OSMC build, from 2016.05 to 08, and now it’s as slow as my pi3.

Something in speedtest-cli got messed up in one of the OSMC builds after 2016.05 ?

There is nothing which has changed that would influence internet speeds and I can confirm my speedtest check have not been changed in the last 12 months.

osmc@osmc:~$ ./speedtest-cli 
2016/09/18 14:45:00
Retrieving configuration...
Retrieving server list...
Testing from Hong Kong Broadband Network (
Selecting best server based on latency...
Hosted by Atombase Global Datamation (Hong Kong) [26.21 km]: 6.826 ms
Testing download speed........................................
Download: 93.36 Mbit/s
Testing upload speed..................................................
Upload: 42.76 Mbit/s

So my suggestion is to first check in your LAN. The crucial question there is how are you connected to the LAN, Ethernet or wireless?

Ethernet, not wifi, although i also tried with wifi and got same results.

I checked in three ways to rule my network out

  1. by interchanging the pi2 with the older vesion that works with the pi3, no change in behaviour.
  2. by using iperf3 to verify local speed between the pis and also to my laptop , both look fine with 96ish mbit
  3. connecting the pi3 directly to my modem, still slow

There are no indications that my network is the cause

I got suspicious on the software so I ran apt get update etc om both and voila, the pi2 is now as slow as the pi3… it could be an update to speedtest-cli perhaps?

Well would be strange, but maybe to exclude that use this version to test

wget -O speedtest-cli
chmod +x speedtest-cli

If that gives you better results than just remove the apt version if not then just remove this version and keep on searching.

No difference, still slow.

Is there any way to revert OSMC to a previous version?

Have you checked speedtest is selecting the same server it did before the update?

Have you noticed playback issues?

Have you checked with your ISP for connectivity issues?

You can download an older version from the website, however I suspect that won’t be the problem

The results are consistent regardless of what server (of those nearby) that is being used

Not sure what playback issues mean?

I run the speedtest html test on my laptop and get good results, also when I use the LAN cable for the rpi - with the same testserver

I am open to suggestions, but from what I’ve tested I feel it pretty much rules out everything other than the OSMC or the speedtest-cli version.

I will now to to install 05 version on the rpi3

Edit; Testresults from win7 laptop and pi, same server, same port in modem, and on the same cable

Also, logs before and after OSMC update:

Date Ping Download Upload
September 17, 2016 at 02:06PM 44.117 44.18 11.01
September 17, 2016 at 03:06PM 58.365 62.86 7.82
September 17, 2016 at 04:06PM 46.361 57.78 11.07
September 17, 2016 at 05:06PM 50.367 44.36 11.19
September 17, 2016 at 06:06PM 47.212 50.17 11.07
September 17, 2016 at 07:06PM 46.163 51.61 11.09
September 17, 2016 at 08:06PM 48.37 55.2 11.2
September 17, 2016 at 09:06PM 43.453 52.11 11.08
September 17, 2016 at 10:06PM 42.948 43.6 11.04
September 17, 2016 at 11:06PM 45.899 52.22 10.69
September 18, 2016 at 12:06AM 96.887 8.2 4.45
September 18, 2016 at 01:06AM 46.798 58.09 8.85
OSMC updated to 08
September 18, 2016 at 02:07AM 2548.037 10.02 2.25
September 18, 2016 at 03:07AM 2568.287 8.73 2.22
September 18, 2016 at 04:07AM 2545.548 9.54 2.27
September 18, 2016 at 05:07AM 2549.04 10.03 2.17
September 18, 2016 at 06:07AM 2550.878 9.79 2.25
September 18, 2016 at 07:07AM 2551.313 10.2 2.37
September 18, 2016 at 08:07AM 2547.918 10.26 2.35
September 18, 2016 at 09:07AM 2548.881 9.94 2.33
September 18, 2016 at 10:07AM 2545.73 10.19 2.35
September 18, 2016 at 11:07AM 2549.917 10.15 2.38
September 18, 2016 at 12:07PM 2544.423 10.23 2.4

There’s a days difference there. Verbose logging and check it is same server

As I say, if you have no playback issues, you probably don’t have a problem, and it may just be the server you are testing from. speedtest cli and the desktop version often pick different servers.

No one else has reported lower speeds, so I’ll guess that it’s an environmental issue, unless you can produce some logs to suggest otherwise

For the logging on the pi2 ive pasted I have been using a static number for the server (speedtest-cli --server 3672) so the difference can not be explained by another server being used - unless the number indicates its not always the same server…? I just checked now, and it is the same server I used the first time though.

As I mentined I made a fresh install of OSMC 05 build and ran speedtest again and now its good on the pi3 so I guess I’ll just use that version instead, too bad i updated the pi2.

Two tests now

Pi3 with 05 build of OSMC

osmc@osmc:~$ speedtest-cli --server 3672
Retrieving configuration…
Retrieving server list…
Testing from Ardalsnett (…
Hosted by Telenor Norge AS (Oslo) [219.43 km]: 51.211 ms
Testing download speed…
Download: 63.99 Mbit/s
Testing upload speed…
Upload: 11.16 Mbit/s

Pi2 wich was working just fine until 08 of OSMC as shown in the previous log

osmc@osmc-tv:~$ /speedtest-cli --server 3672
Retrieving configuration…
Retrieving server list…
Testing from Ardalsnett (…
Hosted by Telenor Norge AS (Oslo) [219.43 km]: 2549.131 ms
Testing download speed…
Download: 2.76 Mbit/s
Testing upload speed…
Upload: 2.37 Mbit/s

You are using data from a different day, so it’s not relevant.

If you downloaded and installed the May version, speedtested, then updated and speedtested and saw a regression, then that could be interesting.

No, the test I pasted in the previous post was done about one minute after the one above was executed, that is the whole point…it’s not from the previous log…

The may version works, the august version don’t. Is there any alternative to speedtest-cli to rule it out? public iperf3 etc?

Sure – you can use iperf if you have a remote host supporting it.

The results would be interesting, perhaps from other users too, as you seem to be the only user reporting this.

As @popcornmix suggests, it could be a DNS issue. In a recent version of OSMC, we fixed a bug where DNS servers were added to /etc/resolv.conf in reverse order.

Try setting the DNS to in /etc/resolv.conf and see if this helps. If it does, you may have a slow or non responsive DNS server on your network

A small update.
I’ve been running speedtest-cli with great success in the 05 version of OSMC until i today installed pihole.

Now the performance is bad again, in the same terms as before. I looked into my DNS settings and in the router the default is set by my ISP to something other than and I am unable to change it, so this may be the cause - but it is odd that it works fine with the specific version of OSMC (without pihole …)

It seems you’re changing / tinkering with network settings. As there haven’t been any other reports of this, I’d suggest this may be the problem.

A debug log will likely clear things up.

You can always adjust /etc/resolv.conf to add and see if this improves network performance. I suspect that it will.

Update 2: I changed the dns server locally to in the file you suggested and speedtest now performs well. I am not sure how this works with the dns in the modem/router from the ISP but for now it seems OK :blush:

Thanks for reporting back. Glad you got it solved.