Slow motion IPTV after fresh OSMC install


After I reinstalled OSMC on the Vero4k all channels are like in slow motion. The picture is smooth but just slow. Could it be that I have to install something additional that was preinstalled on the Vero 4k? I use as always the PVR Simple Client. Streaming from channel media libraries runs normally. Also, the iptv channels on the PC run normally.

Thanks for help!

Not very confident that this will help, but are you using a whitelist? If you are, you might try de-whitelisting 1080p/25, 1080p/29.97 and 1080p/30.

No, I don’t use whitelists but I just read your interesting HowTo. I will try that out once I could solve my problem. Thanks anyway for the input

I have not yet been able to solve the problem. According to VPN tech support, the problem “may” have to do with the current DNS configuration. I had to change it because zomboided’s VPN Manager reported network problems when connecting.I followed their advice:

sudo su
cp /etc/resolv.conf /etc/resolv.old.conf
rm -r /etc/resolv.conf
echo -e “nameserver"”\n"“nameserver” >> /etc/resolv.conf
chattr +i /etc/resolv.conf
reboot now
This worked and the VPN now connected without any problems, but this (most likely) caused the problems mentioned in the topic. Tech support now recommends restoring the old /etc/resolv.old.conf… I like to think that this will solve the problem, but then I’m back to square 1 with not being able to connect to the VPN.
Is there a way out of this endless loop?

Does your VPN have to stay on from start till end, or do you rather want to start and stop it?

Since ZVM, has a hack for doing this with systemd and it works on LE, I suspect it’s a “connman”-issue, I solved it with starting the vpn at startup.

But it rather easy to force ZVM to run a custom script doing just what is suggested at VPN-start and reverse at stop, just haven’t tried to implement it since I changed to VPN client in the router and just have VPN-route for certain clients.

Actually I wanted to switch it on/off, because for me it doesn’t make sense to run all the traffic over the VPN if it only needs it for a small part. But if a perm connection solves the problem, that would also be ok for me. Basically, I’m just looking for a way to make it run as easily as possible

Just to make sure I understand you correctly: You used an untouched osmc DNS resolver and you could fix the problem by having the connection established at startup? How did you do that? I saw a HowTo for this here that was longer than the Bible, so that put me off a bit.

Let me get back to my notes, check if I can set it up like that again, then I’ll get back to you with a simple, step by step instructions. Saturday at the latest. But as I understood it, you prefer fix DNS when enable/disable it in ZVM, if that is possible. Else start VPN get started at system boot up, which I know I fixed, just don’t remember what files/settings I changed by heart.

I rather make a fix for ZVM, to start and dtop with the addon, because I read somewhere that ZVM now can VPN per addon.

Read back my notes, this is expecting you have configured your VPN client already:

Set static IP
Enter the two dns-servers your provider gives you.
Systemctl enable OpenVPN

But most VPN providers won’t do public resolv, so name resolution won’t work if you stop OpenVPN service.

I was considering editing the service file to run a script to do a resolve.conf change, but I’m unsure if connman allows it even if you set IP manually. What I was thinking of trying was, a bash script that toogled between resolve.conf and resolve.conf.vpn. Where system boots up with resolve.conf pointing at known public dns-servers(google/cloudflare/cisco/local pihole or your ISP’s dns settings) which you added in your manual ip settings in MyOSMC. You start openvpn service and a PreExec statement starts the bash file that mv reslove.conf resolve.conf.isp and then mv resolve.conf.vpn resolve.conf. When you stop openvpn service, it runs the script in “reverse”. But as I said, I’m not entirely convinced connman will let resolve.conf be if you change it manually, even if you have manual IP set.

There is a built-in update-resolce.conf that comes with openVPN but it’s built for /bin/resolveconf which isn’t a part of OSMC.

Read someone did try to rewrite that script to use resolvectl. With no luck, yet.

Thank you so much! Unfortunately, I could not test it out yet, I was very busy with other things in life in the last few days. I will test it out the next few days and thank you in advance,


Hello again

Unfortunately, I must admit that I am overwhelmed with this problem as a technically limited gifted person. I have spent a lot of time without any satisfactory result, so I have now come to the conclusion not to pursue the VPN problem any further for the moment.

I must add that the slowmotion problem may have arisen independently of the VPN configuration. I reinstalled OSMC again and the slowmotion problem in Live TV reoccurs. I have been with this IPTV provider for several years and never had this problem. As already mentioned, everything runs fine on the PC but also on other boxes such as a MAG box.I also noticed that from the beginning I had picture quality problems on the Vero 4k+ in single FHD channels, which do not exist on the old MAG box, where they run fine. I always thought that these few problems were due to the stream source and did without them, although they would be important for me. With the MAG box everything is fine, but there I miss again add-ons like opensubtitles. By the way, this also loads many times more extensive playlists in seconds. The Vero 4k+ already has enormous problems with the five times smaller amount. . This is only a side note.

Currently, the Vero4k+ has the persistent slowmotion problem on ALL live channels (but not in the VODs), so I’m at a loss at the moment. I’m getting tired of reinstalling OSMC over and over again only to find out that the problem comes up again afterwards and I’m thinking about changing the box.

Kodi 19.3 has a newer version of ffmpeg which fixes some Live TV issues.
I’d suggest waiting for that and seeing if the issue persists.

Thanks Sam, unfortunately the new package has not brought any change. LIVE IPTV remains impossible to watch in the Vero4k+. Am I the only one who has suddenly encountered this problem? Would it possibly be worth it for me to downgrade osmc?

Can you please post some new logs so we can check?



New logs

2021-11-26 23:52:11.371 T:3059 INFO : CVideoPlayerVideo::OpenStream - could not open video codec

That’s odd. If you enable debug logging and reboot I should be able to get more information.

Have you actually confirmed if other files play OK? Is it only LiveTV affected now?

I will search for option debug logging in the evening and reboot.
Yes, I can watch movies using EmbyCon or VOD just fine, only Live TV is affected.

@sam_nazarko I restarted with debugging mode enabled and reproduced the error. After that I wanted to upload the logs in MyOSMC but now it always says “URL could not be retrieved” (right after the seemingly working process of uploading logs) I don’t have an SD card here right now.