Slow MPEG video rendering after installing OSMC

HI,

I have installed the new OSMV on my raspberry pi and I have a video TV playlist source (UDP) and the video is in MPEG2 format, but the video quality is quite bad and is not sinced with the voice.

I have installed the licence for MPEG2 but id does not help.

I have also checked if the licence is installed with :
vcgencmd codec_enabled MPG2

but it say that it is disabled. I dont understand why I have the licence in config.txt and is the same as in the previous rasbmc install.

Any hints?

1 Like

It must be a typo or maybe an inadvertent space inserted in the beginning? Or possibly the codec belonging to another pi?

I will check the file again I have copied the licence key so there should not be typos

You should not copy paste these keys when entering. Doing so can insert line endings etc, when transferring between systems, particularly between windows and linux systems. iOS devices also used to have issues when entering keys by use of some of the on screen keyboards used in some of the XBMC remote apps.

I have the same problem. I added the line given to me in the license, After booting OSMC, I went to MY OSMC>Pi config>GPU Mem & Codec and the MPEG2 code is there but on the next line above, it shows disabled and I don’t know how to enable it`.

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.

Easiest way is just execute grab-logs -A

Did you reboot after entering the code ?

If you did and it still says disabled then you have entered the wrong code.

Make sure you are not entering the code for a different Pi and make sure you provided the correct Serial number for that Pi when you originally ordered the code.

I am red faced right now. I entered the wrong serial number!!