Slow NZB download speed with external HDD

  1. I set up NZBget and also added a small external (powered) USB (7200 RPM) HDD.
  2. The mount points are set and NZBget is up and running.
  3. Note that the external HDD is exfat format. I have installed the exfat utils so i can read and write to the drive.
  4. The NZBget download home directory is the external HDD.

Issue is that the download speed for NZBget is very slow. The PC is able to get north of 100Mb/s, but Vero 4k+ is averaging 700Kb/s … like 1% of the speed.

Thoughts on what I should look for ?

My experience is, that it does not make any use to download NZB files with a vero 4k+.

I have used sabnzbd with similar experience as @veropiper and the result was unsatisfying in terms of download speed and transfer rates (from the at vero attached HD to a PC).

Dunno, I used Sab and had a 100mb line and was downloading at that speed

I was thinking about a vero Usenet setup too but in the end decided to leave it to my pc. Mostly because the thought of unpacking and potentially repairing a 50 gb file on the vero gives me anxiety :sweat_smile:

Check CPU usage with top or htop.

Looks like it is KODI for the most part.

The DHD_DPC process also peaks every few minutes.

DHD will be WiFi related - you may find improved performance on a Wired connection, but I’d be surprised if it’s significant.

Not sure why WiFi would peak. I’m on hardwired connection.

I’ll keep looking. This is a secondary setup so It’s not a dealbreaker.

Thanks for your help.

You might check the network section of the My OSMC add-on and make sure wifi is disabled.

I’d noticed recently on a Pi using raspbian (not OSMC) that download speed was consistently low.
I turned off “FlushQueue” and it now maxes out my speed more frequently.
Just make sure you read the info with that setting to see if you’re comfortable disabling that.