Slow opening RAR files

In the past I have been a user of OSMC running on a Raspberry Pi and KODI on an Xbox One and I have now upgraded to the Vero 4k+.
After pointed OSMC to my libraries and enabling Archive support in the Virtual Filesystems I updated my library. This found all the files I have that are in RARs. If I try and play a RAR it takes around 25 seconds before the video starts. Previous experience is around 5 seconds.
Is there a way to speed this up or is there a setting I’ve neglected to enable?
Thanks for any direction.

how are you accessing your library ? (usb, network etc.) you literately given us little to go on

Sorry for the lack of detail. Never really posted much for help as I’ve usually found the answer myself.

Anyhow, I’m connecting to my PC over WiFi using SMB share. This is the same way I’ve always accessed my media hence the original Q with the slowness.
Is there a particular log I could capture and upload to assist further?

WiFi performance can change over time. Suggest to check throughput between Vero and your PC with iperf3

I’ll certainly do that but I don’t think that’s the issue as Vero instantly starts and plays a 17GB 4k film with 5.1 sound yet is struggling with 400MB RAR file.

I know I can extract all the archives, and I’ll do that if there’s no fix, but this used to work no issue on inferior hardware.

Well you can enable debug logging and upload logs after trying to play a file maybe something pops up.

Which add-on are you using to enable RAR support?
I seem to recall there being two, with one working better than the other.

I tried both. The RAR archive support add on didn’t appear to work but the Archive support add on did, albeit slowly.

Can you put one of those files on a USB connected drive and see how that acts. Also was this previous experience on other devices pre Kodi 18? I have never personally played with any of the archive support but I have seen posted that when Kodi moved this feature from internal to a plug-in there was some degradation in how well it worked.

Thanks for all your help and advice. I’ve just discovered the wonderous utility Sonarr which necessitates the unzipping of archive files for it to work properly so I no longer require osmc to read them.