Slow read/write to network share

Hi there,

I’ve got Raspberry Pi3 with OSMC installed
Apple TimeCapsule 4th gen as wi-fi router and network share disk

Mounting Time Capsule disk via fstab:
//10.0.1.1/Data /mnt/tc cifs x-systemd.automount,noauto,user=admin,pass=********,rw,uid=1000,iocharset=utf8,sec=ntlm,noperm 0 0

As a result, I am getting extremely slow read and write speed to /mnt/tc
About 1 MB/sec

adding cache=loose option can increase up to 1.5 MB/sec, which is slow as well

Tried afpfs-ng. Reading is up to 3 MB/s, writing no more than 1 MB/s

Also tried to make another samba share from MacBook - same speeds, so Time Capsule doesn’t seems to be a bottle neck.

Measuring reading speed with
dd if=/mnt/tc/temp1 of=/dev/null bs=4k

If I measuring my internet connection speed with speedtest:
curl -s https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py | python
Download: 32.60 Mbit/s
Upload: 33.82 Mbit/s

So, networking in raspberry looking fine as well

Why there is such poor network share performance?

First off, please provide full logs.

I know little about the Time Capsule other than what I just found searching on the Internet. It might be that the poor network share performance is due to some compatibility issues between Debian’s and Apple’s implementations of SMB. Do you see such poor performance from the MacBook using SMB?

If you want, you can try an iperf3 test between the Pi3 and MacBook. If you see somewhere around 90 Mbits/sec, that will at least eliminate one factor.

What kind of logs do you like?

No, MacBook works perfectly with TC

Will try and post it here, thanks

Run grab-logs -A from the command line and let us know the URL.

https://paste.osmc.tv/ufizipefaw

 $ iperf3 -c 10.0.1.4
Connecting to host 10.0.1.4, port 5201
[  4] local 10.0.1.101 port 54840 connected to 10.0.1.4 port 5201
[ ID] Interval           Transfer     Bandwidth       Retr  Cwnd
[  4]   0.00-1.00   sec  4.58 MBytes  38.4 Mbits/sec    0    103 KBytes       
[  4]   1.00-2.00   sec  4.51 MBytes  37.8 Mbits/sec    0    103 KBytes       
[  4]   2.00-3.00   sec  4.50 MBytes  37.7 Mbits/sec    0    109 KBytes       
[  4]   3.00-4.00   sec  4.66 MBytes  39.1 Mbits/sec    0    109 KBytes       
[  4]   4.00-5.00   sec  4.66 MBytes  39.1 Mbits/sec    0    116 KBytes       
[  4]   5.00-6.00   sec  4.59 MBytes  38.5 Mbits/sec    0    122 KBytes       
[  4]   6.00-7.00   sec  4.74 MBytes  39.7 Mbits/sec    0    122 KBytes       
[  4]   7.00-8.00   sec  4.96 MBytes  41.6 Mbits/sec    0    185 KBytes       
[  4]   8.00-9.00   sec  4.81 MBytes  40.4 Mbits/sec    0    185 KBytes       
[  4]   9.00-10.00  sec  4.44 MBytes  37.3 Mbits/sec    0    185 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  46.4 MBytes  39.0 Mbits/sec    0             sender
[  4]   0.00-10.00  sec  46.1 MBytes  38.7 Mbits/sec                  receiver

You’ve run grab-logs -a. It needs a big A.

I’m sorry)

big A URL is https://paste.osmc.tv/ahonutizog

I think you need to try a wired connection between the Pi and the Time Capsule and see what the read/write performance is. I’d recommend you also switch off openvpn during the test.

Well…
I did fresh install of OSMC (just in case)
Wired RPi with TimeCapsule
Disabled openvpn
Read: 9 MB/sec
Write: 8 MB/sec

Guess thats the point. But its impossible to use this setup permanently: don’t want a cable across the room :slight_smile:

What do you think of external usb wi-fi dongles? Would it be better than internal wifi?

Definitely

Actually, it is!
Connected old dongle and now I got around 5 MB/seс for reading
Funny thing the writing speed is 1-2 MB/seс faster (5-6 MB/sec)

Is it maximum, I could get using wifi and time capsule? I guess this is good enough for streaming 1080 videos…

Well next step would be a 5Ghz dongle

Will try! Thank You!)

Thanks a lot for your help! :slight_smile:

Would you didn’t state was the channel you were using on 2.4GHz wifi. There are only 13 channels and every router defaults to channel 1,6 or 11. Changing the channel to either 3,4 or 7,8 can make a huge difference. You can loose as much as 15% per adjacent channel.
5GHz has more channels but for same transmitting power you will only get half the range as 5GHz is more rapidly absorbed than 2.4GHz, however there are many more channels and adjacent channel interference is less of a problem.

From the log

Feb 27 22:45:34 osmc wpa_supplicant[338]: wlan0: Trying to associate with 70:73:cb:ba:74:39 (SSID='Home Network' freq=2412 MHz)

2412 MHz = Channel 1