Slow & Systematic wake-on-lan since kodi 20 update

Hello there,
Since updating to kodi 20, every time I play a song or a film, my Vero 4k+ goes into Wake-on-Lan first, then into Extended search…
However, I didn’t change my hardware before and after the update, so I’m wondering what this is due to. My local network is a wired 1Gb

Thank you in advance for your help

Can you provide some more details and some logs. For example is your network source set to sleep and you had already enabled the WOL Kodi setting but it is now taking longer or ???

As for extended search, what do you mean by this? You hit select on a library item and it brings some add-on? I’m not familiar with what “extended search” is. I know about global search and extended info.

Hi many thanks for your reply,
I’m not sure about the logs, but I think I’ve seen this option. How should I proceed?
My source is a Synology NAS, with permanent fast access from my PC, no sleep settings have been set.
I have tried enabling/disabling the WS-Discovery options in Kodi with no change.
Sorry for my translation, I’m not fluent in English, the exact on TV screen message is: quote “Wake-on-LAN (DS920) Extended wait for server to wake up…”
But I can assure you that it’s perfectly awake :wink:

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

That setting is related to being able to find computers on your LAN. The setting that would be relevant is in settings>system>power savings>try to wake up remote servers on access. When enabled it sends out what is called a magic packet that is able to wake or turn on a computer that is configured to respond to it, and then it waits for a response. If you disable that setting it will remove any delay associated with that process.

1 Like

I tried to reproduce the problem by activating debugging beforehand, but since then all the files opened without delay, really strange, is my box haunted? :face_with_open_eyes_and_hand_over_mouth:
If it happens again, I’ll reinstall a clean version.
Anyway, thank you very much for your patience and help.

I don’t recall any reports of confirmed preternatural events relating to any Vero so I would think this to be unlikely.


Hi Darwin,
The problem comes and goes so I decide to reinstall a clean version.
I downloaded “OSMC_TGT_vero3_20230606.img”
Apart from that, I couldn’t find on the forum the procedure for installing from a USB key.
Would you be so kind as to tell me where I can find it?
Thanks again for your help.

if you look into this page installers you’ll be able to download the installer suitable for your O.S. (Windows, Mac, Linux).
You will then open it and follow instructions.

1 Like

Thanks, I am on Vero 4k+, I guess Vero is under Linux so should I use that one ?

the installer shall be run out from Vero but from a PC or MAC since it’s going to download (if you do not already have the proper image file from the same web page) the image file, format the usb pendrive or microSD and write down the required files.
Then you’ll plug in the pen drive or microSD card and boot Vero 4K from it.
A perfectly clean system will then be rewritten over the existing one.

1 Like

Your solution did not work, pendrive loaded with the img file did not boot at startup, maybe should I had to create a bootable usb drive ?
Anyway, I found under updates/manuals controls an option “Reset Kodi on next reboot”, so far so good, it seems that it fixed all issues.
Thanks anyway :wink:

Did you just copy the image file to the drive?
This is not the correct way.

Nope, but would appreciate to know how to proceed if needed :slightly_smiling_face:

On the download page there is links for different operating systems. So if you have a windows PC, you would download the program for windows. You would then plug your storage medium into your PC and Run the program you downloaded. It will step you through a few options and then after a warning erase the drive you selected and write an image to it.

That’s it, I’ve understood, it took a long time… thank goodness you’re so patient! :handshake: