Smart playlist issue after Oct update


I’m unsure if this issue is related to the Oct update or my own settings, but the playlists were functioning fine/normal until the update.
The menu items I’ve set up on my Vero all direct to smart playlists. Up until the update, the scraper would work just fine for all videos in the playlists.
However, now with the playlist for TV series, it is showing multiple copies of the same files/episodes.
From what I can tell it is now picking up extra folders starting with /.@__thumb/
As such there are (at least) 4 copies of each episode being listed, but only one of these (the actual file) is able to be played.

ie the smart playlist directs to :
nfs://ipaddress/NAS/Movies/TV series/

Then folders are labelled
Name of TV show/Name of TV show S01/EpisodeName

The extra “episodes/files” it is picking up are
Name of TV show/Name of TV show S01/.@__thumb/defaultEpisodeName/
(or something very similar)

I can’t for the life of me figure out how to exclude these folders from the scaper in the playlist. It seemed to do it automatically prior to updating

Here are the logs -

Hopefully this issue makes sense the way I’ve described it.

Thanks in advance,


Workaround, sort of
Within the TV smart playlist, I can add “Path does not contain /.@thumb/”

So I guess, I’ve kind of solved my own issue, but I distinctly do not remember having to add the exclusion rule to the playlist previously.

Note scraping for movies is working just fine.


I’m a bit curious how this could be happening. Does the duplicates happen in the normal library view, or just the playlist? Can you paste the contents of that TV smart playlist?

I’m curious too. I get that it’s picking up the extra folder given the way the playlist was set (ie Path contains), but they appear to be ‘hidden’ folders/files and weren’t picked up before.

Now, just to make things more confusing, the issue appears to have rectified overnight (and I’m pretty sure there was no update…).
It’s not in the normal library view now, but I dont know if that is because it never happened or if it is fixed itself.

This is the smart playlist I had set up as a workaround

This morning I deleted that second rule (Path does not contain…), rebooted, updated library etc, and the issue has not recurred.

This is what I could find in the folders themselves (sorry not really a linux/putty person, so this program was easier for me to work with).
Had to enable hidden folders/files to see the aberrant folder (could not see them at all through windows or the NAS interface).

The folder with the actual episodes (you can see the .@__thumbs folder)

Contents of .@__thumbs folder

Contents of the .genSub folder

Hopefully this helps,


It looks like you NAS is making those thumbnails which apparently you can stop if you don’t want them. I think you are scanning those thumbs into your library which is not something you want happening. If you decide to stop your NAS from making them and delete all those folders and their contents then you can run a clean video library and that will pull them out of your database. If you want to keep them for some reason you will have to add a library scan exclusion in Kodi so they are ignored. I’m not sure how you would automatically remove the bad entries in that case though as it only ‘cleans’ entries that the files no longer exist.

That is an illegal folder name (because it starts with a period) in windows so most windows programs and utilities have no ability to display it.

And FYI that is not a playlist, it’s a widget.

Sounds to me like an issue all Synology NAS users could have (here this internal directory created by the Synology indexing is named @eadirand for this I have since years the following entry in the file



See here for more details.

So, give it a try, adapt it to your purpose and let us know.

Idea for the root cause: Have you enabled some media indexing service on your QNAP NAS last time which you’ve not used before?


Yep, thanks for the help. Was the QNAP creating the thumbs. Have turned media indexing off (as per

and deleted the folders and all is well. Still unsure as to why the Vero only just started to pick them up (hadn’t changed anything on the NAS), but problem is solved now so all is good :slight_smile:

Nope, but it turns out it has been switched on for years, just never had an issue with it prior.

Thanks again for your help

Did you happen to have turned on settings>media>general>show hidden files and directories in Kodi before this happened (the preceding dot in linux designates hidden attribute). Regardless they are not something you want needlessly clogging up your database even if they were not being displayed.

I don’t think so. In fact I think I remember turning that on after finding the issue as part of trying to figure out where the files were located.

All fixed now though. They’ve been nuked from the QNAP and media indexing turned off.