SMB connection issue after June update

I, too, am experiencing this problem… but my media is on an older NAS which can’t do SMB3; I’m stuck with SMB2. I tried an NFS share, which allows the media to play but without any transport controls… so I’d be really grateful for the SMB2 fix.

For our understanding, is this also a Synology NAS or a different brand?

Can you explain what you mean without transport control?

If you don’t want to wait for the fix you also could switch to kernel based mounts (eg autofs).

I will produce a new build to address this tomorrow.

Thanks for your reply. :slightly_smiling_face:

Correct, not a Synology box. It’s an old D-Link DNS323 on Alt-F firmware. Not enough ROM to update Samba as far as the developer says. It’s old and slow but it works for me as a media server.

No transport controls = no play/pause/stop etc functionality in Kodi - I only get this behaviour when playing a media file on an NFS share. SMB shares are usually fine. Very weird.

Either way… If a fix is coming soon it’s no big deal for me to wait a bit. Frankly being forced away from the TV is something I really need right now… :smiley:

Thank you all!

1 Like

Thats really strange and should not be related to the switch from SMB to NFS.

I’ve pushed a solution that should work for everyone, but needs some testing.

Can someone please adjust their NAS settings back to how they were and try the following update?

Under Settings -> Services -> SMB Client, there is a new setting: “Fix issues MTU issues with SMBv2 NAS devices”. This is enabled by default and should resolve the issues you have been experiencing. If you uncheck the box, the issues should occur again.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

1 Like

Hi,
The fix works here:

  • with “Fix MTU issues” enabled and SMB2 on NAS: OK
  • with “Fix MTU issues” disabled and SMB2 on NAS: Error
  • with “Fix MTU issues” disabled and “SMB2 with large MTU” on NAS: OK
  • with SMBv3: OK

Thanks.

Confirm success on the D-Link DNS323 with the published fix.

Fix on = OK
Fix off = original issues resurface.

No undesirable behaviour discovered.

Thank you!

I had the same problem with June update and the SMB MTU fix works for me as well

2 Likes

I had the same problem, and it’s fixed with that solution. Thanks.

Has this been merged into the June update yet?

Yes.

I can also confirm the fix is working.
„Mitigate MTU issues“ on: all files are playing normally

Hi, I have just applied the June update but don’t have the new MTU option under the SMB client service. I thought the fix was merged?

It was. Please post some logs so we can see which version you are on.

Sam

https://paste.osmc.tv/biluberima

You don’t seem to be using a Vero.
This only applies to Aarch64 platforms.

Since the June update it doesn’t scan my Nas and all the art etc has disappeared. I can play things only by going into files.

Then you should probably create a new, relevantly titled thread for your issue that includes debug enabled logs and we can take a look from there.

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

I had the same problem… fixed by @sam_nazarko 's post. Some of these updates need to come with Warning Labels :grin: