SMB connection issue after June update

Hi, ever since I installed this update my Vero 4k has been unable to play most movies and some series. Here are my logs, I have not been able to figure out why it’s not working,

1 Like

HI @j.davids

I have moved your post to a new thread as we normally don’t do the troubleshooting in the announcement thread.

From your logs it seems Kodi has connection problems with your SMB server.>

2020-06-05 01:05:41.784 T:3595256544   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://USERNAME:PASSWORD@'
                                            unix_err:'67' error : 'Software caused connection abort'

Did you try to reboot the Server? Can you give a bit more background what Server (Software/Settings) you are using?

Hi, sorry for posting in the wrong section.

I have rebooted my NAS and tried changing the SMB protocol version in OSMC.
I am running a Synology DS216j on my local network.

I am fairly certain it is not an issue with the server since I can play certain series/movies but am having issues on most, on top of that I do (on some) see the first few second. The error you posted from my log is weird since that was actually something I am able to watch.

This is the error I am stuck on:
2020-06-05 01:04:59.077 T:3324420832 ERROR: Read - Error( -1, 103, Software caused connection abort )

Yeah that’s odd. It could be a network problem (maybe test with iperf3).
For further checking suggest to enable debug logging with component-specific logging for smb.

Also maybe check if your VPN gets into your way.

I have no clue how to use iperf3 also can’t find the component specific log either. (no VPN either)

From your logs>

Jun 05 01:08:18 Vero-JoramD systemd[1]: Started OpenVPN service.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for all components

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

I enabled the debug logging, reproduced the issue but now I can’t seem to upload the logs. I just get Logs available at<html> using both normal and SSH methods.
Ran the iperf3 test, no issues there.
And I can’t for the life of me find anything to do with OpenVPN.

That could indicate that the logs getting too big (because of the debug logging).

You could login via ssh and try either paste-log .kodi/temp/kodi.log

That’s because the logs to big. Reboot twice and reproduce the problem again.

It would help to see the results of the iperf tests. People think that the results are just fine when they are showing problems.

You must have installed it one day. If you are not aware of it just remove it with sudo apt-get remove openvpn

This is saying the file is too big

Did you reboot twice as I suggested?

Yes, did that before every attempt.

cat .kodi/temp/kodi.log | grep -i smb | paste-log

Maybe try to reduce the component level logging just to SMB, the original guide I gave you would have enabled all which is not needed.

Finally reducing it to just SMB worked:

On a side not, does the copy to sd card option not work?

Now I can go reinstall OSMC…
Something with the postfix osmc was dependend on openvpn

Something is flooding your Vero with Json requests.
Maybe for troubleshooting disable the Webserver (Settings -> Services -> Control)

2020-06-05 04:59:31.819 T:3673170656   DEBUG: CWebServer[8080]: request received for /jsonrpc?Application.GetProperties
2020-06-05 04:59:31.820 T:3664777952   DEBUG: CWebServer[8080]: request received for /jsonrpc?Player.GetActivePlayers

Post the terminal output you got