SMB / DAVS not connecting Synology

#1

Hi

Updated my Vero 4k to the latest April update.

I wanted to add my retro roms folder located on my Synology.

When i try to add a SMB or Webdav(s) connection it fails instantly (both worked fine on v17)

I then tried browsing my music folder which was via smb and worked previously on v17 and that also instantly states “Couldn’t connect to network server”

I can access SMB fine from both my hackintosh and pop_os, as well as via my macbook so i know the synology is not at fault here.

I have checked the SMB settings in services and tried Min SMb unset as well as V2, the synology is set to accept from V1.

Any pointers would be great

I also have now tried adding NFS share - i can see the folders on the synology that are authorised to the vero4k and can add them. Location saves okay but when i then try to browse them again i instantly get the same - couldnt connect error message

Same issue with FTPS however FTP does connect and browse ok

#2

Has the Synology got a static IP?
Can you post a debug log when the connection fails?

#3

Yes it has a static IP, is reserved in my synology router and set in the nas. I will attempt to get a debug log for you

#4

Here is the log

debug log

What i tried -

accessing previously working davs connection
accessing zero config samba and davs connection

these all error out

However after switching debug on, weirdly enough samba connected and standard DAV connected just not davs

#5

Davs is failing because of an invalid SSL certificate:

2019-04-22 14:43:38.454 T:3919573728   ERROR: CCurlFile::FillBuffer - Failed: SSL peer certificate or SSH remote key was not OK(51)
2019-04-22 14:43:38.454 T:3919573728   ERROR: CCurlFile::Open failed with code 0 for https://192.168.1.63:5006/Music/:
2019-04-22 14:43:38.455 T:3919573728   ERROR: GetDirectory - Unable to get dav directory (davs://USERNAME:PASSWORD@192.168.1.63:5006/Music/)
2019-04-22 14:43:38.457 T:3919573728   ERROR: GetDirectory - Error getting davs://USERNAME:PASSWORD@192.168.1.63:5006/Music/

This seems to mesh with a post on the Kodi forum: https://forum.kodi.tv/showthread.php?tid=339413

#6

yep saw that in the log, odd its only affecting 18, but hey ho such is technology, ill just leave it via dav for now