SMB file share help


I’m relatively new to OSMC and pi’s in general spending most of my time with windows boxes.

I’ve recently rebuilt my pi3 to a standard osmc build. Before this it was able to browse the smb shares i have setup on my raspbian pi2 i am currently using as a print and file server.

However since the rebuild I am now completely unable to browse any smb shares at all. I realise through the looking through several help topics that currently using smbv2 & 3 that browsing has been disabled however it would also appear that attempting to connect using the server’s IP address is also not working I’ve tried smb:// which is the smb share details (works fine from the windows machines i have around the house) but the osmc comes back with an error that the connection timed out.
I am using the default username and password and making sure they are entered but still no joy.

I’m hoping that someone can point me to my error so I can get this working correctly again, i don’t want to have to plug my usb storage drive into the osmc pi just to be able to watch files again.

Thanks in advance

Ok, will give you some hints but wondering why you not use OSMC as a print & file server (samba is in the App Store).

  1. you could try fstab based mounts see Configuring fstab based Samba share mounts

  2. Check with smbclient -L how the share looks like you first need to install smbclient via sudo apt-get install smbclient

  3. Enable debug logging and upload logs after trying to access it via smb:/