SMB is empty

I tried adding a video files source by using smb:// in the media path and also tried the name of the machine. The source has been added fine, but it’s just an icon of an arrow with no files or folders listed. I tried accessing the same SMB share from a second Windows computer, and the sharing works correctly.

Enable debug logging. Remove and add the source and upload the logs
https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request

I’d be interested to know what you put in for the hostname.
I found a couple of days ago that using all uppercase hostname worked but lowercase did not.
i.e. smb://MYPC/sharename worked but smb://mypc/sharename did not - where “MYPC” is a Win10 system with all available updates from MS.

You won’t see the files in the source browser. Only when you go back to search the library.

1 Like

Not sure I understand that part. I don’t use the library (don’t like it and never used it on my other Kodi devices either). I go to Files and access my shared directories from there.

However, even without the library, it seems that when you click on Videos => Files => Directory in OSMC, you should be able to access the contents of those shared directories.

P.S. I was trying to quote @grahamh above. How do you quote someone on this forum?

But you said

Sorry, adding a source usually means you are using the library. In that process, you will not see the files, only shared directories.

Can you see the files in Settings->File browser?

To quote, just highlight the text and click on the Quote button that appears.

@fzinken Sources removed and re-added. Logs: https://paste.osmc.tv/okutenoyut

SMB is empty both in Video and in File manager. I have tried adding the following paths:

smb:\\
smb:\\nuc
smb:\\NUC

Try using IP addresses instead of hostnames please.

OK, I added 192.168.0.11. It says “Couldn’t retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?” I chose yes. When you click on that source, it says “Path not found or invalid.” I did verify that this was the correct IP by running ipconfig on the host machine.

Can the devices ping each other from the command line?

Yes, I can ping both the SMB host machine and the Vero from a second computer.

So it’s looking like a permissions issues on the server?

No, it’s looking like a Vero issue. I can access the SMB shares from a second computer, play movies etc.

You are right - not ‘on’ the server but between vero and server. Permissions needs the right settings at both ends of course. If you delete a source in kodi then try to add it again, there’s a screen where you input user and password. It’s badly designed so the words Username and Enter password are barely visible. I just wonder whether you missed that step when adding the source.

The log is empty, please try again

Permissions are set to Read/Write for everyone for the shared directories. I am able to access them from a second computer without inputting a username or password.

That’s guest mode which is not supported on OSMC

That doesn’t make a whole lot of sense to me. Everything worked great in Kodi. Why fix something that wasn’t broken? How do I set up to watch video from SMB shares on this device?

Can I get support directly from the manufacturer of this device? I appreciate your guys’ help, but we’re not getting anywhere and patience is starting to run thin. 24 hours of jumping through hoops, including fiddling with a clunky virtual keyboard to add and remove sources over and over and uploading logs that turned out to be empty, and I still can’t enable basic functionality on a box that I spent $140 on when a 4-year old FireTV does everything fine.

Well I assume @sam_nazarko will take a look at this thread when he gets up this morning.
But also Sam would need you to provide debug logs