SMB logon failure

i just moved my file share from freenas (smb 1.0 disabled) to a windows server 2016 smb share with smb 1.0 disabled.

here is the line i added to fstab with username and password X’d out:
//\040Shows /mnt/TV\040Shows cifs x-systemd.automount,noauto,rw,iocharset=utf8,,password=XXXX,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=2.0 0 0

tried this too:
//\040Shows /mnt/TV\040Shows cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=XXXX,domain=XXXX,password=XXXX,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=2.0 0 0

I also tried replacing version 2.0 with 3.0, didn’t work.
username and password is validated working and the shares and permissions are fine, tested on other windows machines but can’t seem to get it loaded on my vero4k.

running ls /mnt/ shows /mnt/TV Shows but when i try to cd to it, i get the no such device error.
logs show STATUS_LOGON_FAILURE. not sure what to try next.

The issue may be caused by the server being part of a domain.

I would try a command line mount first before adding to fstab.

Install smbclient

sudo apt install smbclient

and then share the output of

smbclient -L ip.of.your.server -U my_username
1 Like

here’s the error message from the smbclient -L test.
protocol negotiation failed: NT_STATUS_CONNECTION_RESET
same error using the domain account and a local username that i gave permission to the shares am using.

Have you read this post:

i have and have been using smb v2 with the previous setup and authenticated using my domain service account on the share too.

what i find odd is how authentication fails even when using a local admin account on the new server. i am able to map the same shares on a chromebook just fine with the same local admin account.

tried this adding -m to for smb versions 2 and then 3, it failed with a session negotiation error.

went ahead and tried to mount via autofs but i don’t see the mounted shares either.
logs at: insert_log_html_here/aruqiyayej
appreciate if you can point out what am doing wrong here too.