SMB nearly unusable on Kodi 18.9

I installed OSMC running Kodi 18.9 on my Rasp 3b+. While Kodi works well, the SMB shares system simply refuses to cooperate.

I’m trying to access a 320GB external HDD connected to the Pi so I don’t have to keep removing it to add new content, plus for general use.

I can see the network location (OSMC) and can access and browse it, and even (very poorly as it loses connection) watch the content inside it from other devices. Thing is, it is incredibly unreliable, and I not once managed to send a large file (such as a movie) to it.

when I try to send such large file to the HDD, windows only does the “discovering” phase, then stops. no error message, the copy just doesn’t proceed. while that happens the server also becomes inaccessible to other devices in the network, and even the pi reboot gets busted (I get a “stop-job” related to SMB or disk manager, and can’t get a clean reboot).

I’ve tried changing the SMB.conf. I’ve tried to use user automount, which didn’t work as that has a known bug. I’ve tried to add smb-shares.conf, which improved the reliability a little (got to transfer a few MBs with no problem). But it’s still very unstable. While browsing, after sending a file to the HDD, the connection is often simply lost and I get an error message saying the network location couldn’t be reached.

This isn’t a wrong free space reporting issue, as I have about 8GB free on the SD card, but can’t transfer even 750MB to the HDD.

I’ll also accept any ideas to make the wired LAN more reliable or faster as I heard the 3b+ hardware handles ethernet poorly.

Any suggestions?

My setup:
Raspberry Pi 3b+
Running last OSMC version and Kodi 18.9 Leia
16GB SD for OS
320GB HDD for media, NTFS
Fully wired, WiFi used only for remote

Edit: Just tried again. 750MB file won’t copy into the HDD, and the network location is now unreachable.

Avoid using NTFS.

1 Like

You should not have any problems to get >85Mbit.
Suggest to check your performance (in both directions with iperf3).

What would you recommend? I don’t want to use Fat32.

This has been exhausting… I though the SMB was working, but so slow that Windows raised an exception. That’s not the case, sometimes it’s not accessible at all.

I’ll try to switch to ext4 in the HDD or something, maybe change the HDD mount point, but at this point I’m considering using FTP and ditching SMB, which would suck since people in my family aren’t tech savvy, but oh well.

It’s literally quicker and much more reliable to upload the videos to a server in Estonia and re downloading than sending them to the device 20 feet from them.

  1. Please upload full logs: from the command line run grab-logs -A or use the Logging option in MyOSMC.
  2. Can you tell us if the 320GB disk has its own power supply?
  3. As a test, please try to set up an SMB share on the SD card and see how that performs. You have 8GB free, so space shouldn’t be a problem.
1 Like

I did try to go the FTP route earlier, before dedicated one sata-drive for writing to from samba & local torrent client.

The problem, as I understand it, is the FuseNTFS, having a hard time writing any file over 500-ish MB in size(samba), or constant data flow over 2.8 mbit/s(ftp). Have no real data, this is just approximated numbers, based on recollection. I had to limit upload speed and then it worked, not accaptable. Fixed up a temp-drive but then the PSU* came into play.

After inserting a smaller 1tb drive for temporary storage(ext4), and scripting an automated “move of files” to the larger 8tb NTFS drive. Now I can’t fault it in normal usage.

*) The smaller drive used a low budget usb2->sata converter and the PSU that came with that worked for like 3 weeks of 24/7 usage, have since then taken an old PSU from a desktop PC and voila.

I have a share on the SD card, that one works flawlessly.

Turns out my problem was hardware. Don’t know what or how, but I tried another HDD (a super duper old laptop HDD I had put into a case) and now it works - with the performance you’d expect out of a 10 year old HDD, but with no errors whatsoever. Guess I should have started troubleshooting from the bottom instead of learning so much Linux in the last few days, lol.

None of my HDDs have their own power supply, so it could be that. The one that works uses exactly the same kind as the one before, though (Y usb cable). Maybe the 320G one was pulling more current than the Pi could handle? I don’t know. Could also be filesystem, but I don’t think so, since fat32 wouldn’t work in a large volume, it’s probably NTFS too.

I’ll try to hook up the 320G one with a powered USB hub and see how that goes. If it works we know. If not, what could it be? A low quality HDD losing connection for no reason?