SMB not accessible

I just did fresh install on my new card but I cannot add SMB shares from my desktop. In previous version (before I changed my SD card) I could see all my shares. Do I have to have Samba installed on my OSMC or something else. I tried adding SMB shares by IP address or a full path name but nothing works!

Please help

Thanks. I did change to SMBv1 and I can see SOME shares but for the others when I try to add them I get “Invalid Argument”!

What am I doing wrong?!?

Can you be more specific? From where are you trying to access them (Windows? Linux? Apple?) and how are you trying to do that?

Sorry, I read this that you had shares on the Pi which you want to access from the desktop. If the shares are on the desktop, you need to check the permissions and the differences between the shares you can see and the shares you can’t see.

I am running Windows 10 and have few shared folders, some on that machine and some on two different USB drives attached to my server. I have no shares on Pi. I have also network drives (I have no problem connecting to those). Till two days ago I had no problem connecting to SMB shares, but when I installed latest OSMC version on my new SD card for the life of me I cannot add as a source on my Pi.

Before I started changing some settings on my Windows 10 server (I used different Googled suggestions of increasing IRPStackSize; increase size parameter in registry; enabling SMB 1.0/CIFS File Sharing Support) I could see and add shares which were physically on my server or drives attached directly to USB port on my server. The problem was with the drive which was connected to my server via USB 3.0 hub. Now when I try to add SMB source on my Kodi ANY folder on my desktop I keep getting - connection timed out.

Mind you all these folders are seen and reachable within the LAN on another computer and PLEX.

Let me get this straight. You have a Win10 server with internal drives and external USB drives. Kodi can see all drives except those attached through a USB3 hub. You have some ‘Network drives’ I assume these are boxes attached to the LAN like a no-frills NAS and kodi can see those. Then you have a desktop (OS not specified) which kodi can’t see at all.

Am I right?

LOL. I am sorry if I am not precise as I should be. My setting is - Pi wired connection can see all “no-frills NAS” but cannot add SMB shares on desktop’s (running Win10) .

When I try to add SMB source on Pi and click add I can see name of my LAN and after clicking on it I can see name of my desktop (where shares are). But as soon as I click the desktop name shared folders do not show and I get “Connection timed out” and “Could not connect to network server”.

Yesterday when I installed latest OSMC with latest Kodi I could see SMB sources (all shared folders EXCEPT shares on my USB drive attached via USB 3.0 hub on my desktop). In order to fix that (previous version of OSMC and Kodi on my old SD card could add these shares) i did change some settings on my desktop (mentioned in my previous post). Now I cannot add ANY of these shares (on desktop drive or on USB drive connected via USB hub.

I hope this is clear enough.

Have you tried to change the SMB protocol in Kodi to SMB1?

Since I am desperate I was reading this forum for all SMB related issues and found that it is possible to mount shares on Pi via fstab. Should I try that?

I did but no avail.

You could try fstab but if even changing to SMB1 in Kodi didn’t help I am not sure if fstab works.
But doesn’t harm to try/

Also here the link to the explaination how to change to SMB1 which helped someone else

I read that you did on the server, wasn’t sure if you also tried in Kodi.

Just now I copied my old “sources.xml” to the new install on Pi and changed back to SMB3 (on Kodi). Old SMB sources now show and when I click on them I can see the content, but if I want to add them as source again in order to scan them into library SMB source is empty?!?

So with context menu I set content (movie and TV Shows) re-scan them and they are in my library.

But still i cannot add any of these with SMB?!?!

Is that wired?

If you are attempting to add as a source, you will not see the content. While adding source you will only see locations (folders/directories), not the files themselves.

Sorry I was not precise - I cannot see location at all -hence no folders/directories. It is empty.

How’s that possible?

What exactly did you change?
At least you should get this situation back by reverting all your modifications in Windows 10 … but who can know what you changed than you alone?

So if you choose Scan to library from the context menu you are all good, right?

Browsing to shares in kodi is problematical as is entering user/password credentials as explained in the linked post. When you want to add a new share, follow the guide.

I changed exactly what I specified in first quote (plus on Kodi itself changed SMBv1. And I did that because I could not add SMB source. After all these changes result is the same I cannot add SMB source.

What is puzzling is that by coping sources.xml from my previous system onto the new one I CAN see them, I can via context menu assign content, scrape them with local info and add into library. So the system can see SMB sources if they are added in previous version but in this new build it won’t allow me to add any of these.

I can only think that if you have multiple shares and have already added some and used them with SMB3, you maybe can’t downgrade the connection to SMB1 to add another share. Try wiping passwords.xml then add the server instead of each individual share:


Once that’s there, you should be able to navigate to each share in turn and add them to the library.

Yeah I am good. But I am just worried that if I want to add another share I will not be able to use it. All my shares are set to be user/passwords free. But what I gathered reading all these threads is that nevertheless you have to provide the one you assign when you installed Win10.