SMB not working again?

Hi all,

I’ve updated to the October release and I just noticed that some, but not all, of my SMB shares are not available. The files are on my server, but they’re not available for selection on the RPi running OSMC.

The videos I’m looking for were available on the RPi before I updated, although I can’t be sure the problem is with the October release.

I tried to “Add videos” as follows: Settings > Media > Videos > Add videos > Browse > Windows network (SMB). The result was an empty list.

I uploaded logs here:

I also noticed that when I navigate to My OSMC, the option that used to be “between” Log Uploader and Pi Config (at “7:00”) is missing. I mention this in case that’s related to my SMB problem.

Thanks for any help.

Do you also have problem with the uPnP-service as well? Just checking because it could be network driver related? I am investigating problems with uPnP which is announced via multicast address.

Not sure about uPnP. How would I tell if I’m having a problem with it?

Acticate uPnP in the OSMC. Download a DNLA/uPnP app on your mobile phone. For example VLC (hit network icon) or mconnectLite (hit the browser icon). You should see a OSMC showing up rather quickly.

I have been investigating problem with uPnP and I think it’s some problem with the network driver. Still investigating. So when you don’t see the SMB-share it could be related.

You could do this test that got uPnP working on my OSMC:

Install on the OSMC tshark:

sudo apt-get install tshark

Run the command:

sudo tshark -i eth0

Test if you see the SMB-share now.

Before I proceed as you recommend, may I ask if you looked at my log file? Is there something in that file points you to uPnP? Are there any other “clues” in the log file that might be helpful to me?

For example, I see some problems regarding access to the following shared directory: //LACROSSE/OTA Recordings without Commercials. This is where the videos I’m looking for are stored. Some of the videos in this directory are accessible from the RPi, others are not. Moreover, this directory does not appear when I try to “Add videos” (see above).

I’m hesitant to proceed as you recommend because I’ve never installed or used the items you describe. I’m not sure why I need to install them now. If you could help me a bit more with that, I’ll proceed as you direct.

Thank you for your help.

It seems that you have UPnP disabled:

<setting id="services.upnp" default="true">false</setting>

Sorry for being unclear. You probably have no problem with uPnP. Just wanted to give some investigative clues to follow, hence checking if it’s a network problem.

Hmm. I’ve never touched this setting. I wonder how it got changed? Do I need to set it to true? Where do I do that in OSMC, or do I need to go to the Linux command line?

Thanks for your help!

I appreciate the help. Thank you. I’m not very good on the Linux command line and I need lots of reassurance before I go there! :slightly_smiling_face:

You didn’t change anything. False is the default setting (which is what default=“true” means)

OK. Thanks. Do I need to change this to “true” to access my SMB shares? If so, how do I do that?

Also, I was able to access these shares sometime before the October update, now I can’t. Something happened. It could have been the OSMC update, but it also could have been a Windows 10 update.

Thanks for any help.

Have you tried using an ip address instead of a name in your source? Maybe just try adding a path substitution to your advancedsettings.xml file to test…

    <to> smb://</to>

NOTE: You would need to find what the IP address of your server is and change the <to> line to reflect the correct address. Also you said you were trying to browse to a SMB path. Browsing this way only works with SMBv1 (not recommended) and I think some people have posted that a recent Win10 update disabled the SMBv1 (not recommended) that they had manually enabled. If you really want to use SMBv1 (not recommended) then you might check in Windows to see if it is still enabled.


I really appreciate everyone’s efforts to help, and apologies for being thick, but I’m missing something basic I’m afraid.

The directory in question is shared in Windows 10 with no password. For at least a year, maybe two, I’ve added videos to OSMC by navigating as follows: Settings > Media > Videos > Add videos > Browse > Windows network (SMB).

In the past, when I’ve done that, I could all my shared directories and could navigate to one to add to OSMC’s videos. Now I can’t do that. I get a blank page in OSMC when I … Browse > Windows network (SMB).

I’ve added pictures to OSMC the same way. Right now, I can see all the pictures I’ve added with no problem. However, if I try to “Add pictures”, I get the same problem when I get to … Browse > Windows network (SMB). I get a blank page.

I’m running Kodi on the server and there is no problem there.

I’m confused that what has worked very well for me in the past is no longer working. I can access some of my videos, but not all of them. I can access all of my pictures. But I can no longer add new pictures or videos to Kodi by navigating to …Browse > Windows network (SMB).

Edited to add:

Apologies, but I missed your last point about SMBv1. I was one of the folks who had the problem with that a couple months ago, so I changed to SMBv2 or SMBv3. The navigation I described above continued to work. I guess it doesn’t anymore. I’m at a loss now. I don’t know where to add the code you recommend. Is that another opportunity for me to navigate the Linux command line? :slightly_smiling_face:

So your existing sources are still working but your issue is only with adding new ones? If that is the case then there is no reason to modify your advancedsettings.xml like that. I would suggest to go to

Settings > Media > Videos > Add videos > Browse > Add Network Location >

And then make sure the protocol is set to SMB and in the “Server Name” field click on it and manually type in “LACROSSE” or preferably, the ip address of your Server, and then click OK. Don’t type in any characters other than just the computer name or ip address. Now instead of going to Browse > Windows network (SMB) you will go to Browse > LACROSSE (or the ip address if that is what you used) and you should be able to see and browse the shares on your PC.

Thank you! I think I’m getting back to where I was. Somehow I missed the option to Browse > LACROSSE and ended up typing in my verbose directory name using the clunky remote control interface. :slightly_smiling_face: I’ll have to go back and see how to browse correctly next time.

I changed an SMB setting a couple months ago when SMBv1 went dead on my server. At that time, I had no idea the “Browse” functionality no longer working. I had visibility to all my shares, and that’s all that mattered to me. All was good. I thought.

Yesterday, I noticed that some three of the four seasons of a particular TV program were no longer visible. All of the seasons and episodes of the other three programs were there, but they weren’t sorted neatly into season buckets, and much of the associated artwork was gone.

I went out to investigate adding the shares back, and that’s when I discovered they weren’t there. I was confused because everything was accessible except 3 seasons of 1 program, but the shares themselves were not visible. Moreover, all my pictures were there but, again I couldn’t see the shares.

One item of note: When I proceeded according to your guidance, I ended up with two shares with the same name, one with (2) after the name. Neither one of them had the three missing seasons of the program I was interested in. I ended up deleting the “old” version of the share, then edited the new version, removed the “(2)” and all looks well now, except I don’t have the neat sorting into seasons anymore. I’ll keep plugging away and try to get that back.

Thank you for your help, and apologies for being so thick!

Just to lessen the confusion, what you were doing before was using NETBIOS to look out to your network to find your server and that requires SMBv1. Current windows will remove that automatically under certain circumstances after a period of time. What I outlined above was basically just a shortcut to your server so you can go directly to it and negating the need for network discovery. Note that this method added a network location which is not the same thing as a source. You ad that and then you can use that as a path for adding or editing sources using browsing thereby avoiding having to type in any file paths manually.

As for you ‘seasons’ issue i’m not entirely sure what you mean. If you are browsing in file mode, and you don’t have your files organised at the file system level into season folders then you are not going to see them that way. Perhaps you are confusing this with viewing this content from the Movies and TV Shows section which are database views and are not tied to how the files are stored.

Thanks for the explanation. I think I understand better now.

My problem with SMB unfolded in two stages. The first stage is documented here. The short story is I couldn’t access any of my shares; i.e. no episodes of any season. I “fixed” it by changing the maximum SMB to SMBv3. After doing this, I could access all my shares again.

The second stage of my problem is the one documented here; I could access almost all of my videos and I couldn’t “browse” to add sources.

Regarding the display issue, I have organized my file names to facilitate ordering the episodes by season with appropriate artwork and thumbnails. This worked very well for me until now. I used to get a thumbnail for each TV show when I navigated to “Videos” on the OSMC home screen. When I clicked on a thumbnail, I got a second-level of thumbnails corresponding to each season. Clicking on a season then provided a list of episodes for that season. I have not been able to recover this organization. I managed to create a “favorite” for each TV show. When I click on the TV show, I get a list of all seasons and episodes; i.e. the display does not sort into seasons. That’s a relatively minor problem, and I’ll keep working on that. I haven’t changed the directory structure or file names on the server.

Thanks again for your help.

If you don’t see artwork in “Videos” then it usually means either the folder is not properly scraped to the library, or you have a single show that has episodes split across more than one source path (which isn’t a problem, but does manifest this issue).

Well, somehow the artwork is all back. I’m not sure why, perhaps because Kodi cycled through a library update or database cleaning or something. It’s a mystery to me, but I’ll take it. :smiley:

Thank you for your help. I now know the full story of what happens when Microsoft deprecates SMBv1!

1 Like

And my uPnP server is working as well. This morning the OSMC said it had to restart for new network settings. And now its working great. So something is changed!

Kudos to the guy who fixed this!