Unable to access SMB shares on RPi solved

Something happened with my RPi recently – I don’t know exactly when it happened – where I couldn’t access my SMB shares. I had a look here and saw references to such problems for the Vero, but didn’t see anything that matched my issue with the RPi. I tried a solution posted in the Vero section that worked for me, so I thought I’d report it here.

I navigated to Settings>Services>SMB Client and noticed that Minimum protocol version was set to none and maximum set to SMBv1. I changed the maximum to SMBv3 and that solved my problem. I can now access all my SMB shares.

Did something get changed in a recent update that caused this problem for me? I’m just curious at this point.

No update of OSMC would have caused that. You must have made that config setting in the past. And I assume the SMB version on your server changed in the meantime not supporting v1 anymore.

Thanks for the quick reply.

I’ve quite sure I didn’t make any changes to the SMB version myself. My server is a Windows 10 desktop, and I’ll bet dollars to doughnuts that something about SMB changed in a recent Windows 10 update. I’ll dig around to confirm that, but the good news is I’m working just fine.

No comment

Well Windows 10 basically started to disable SMB1 2 years ago but was keeping it enabled if devices still accessed via SMB1. So maybe some unused time made Win10 now to disable it.

This article gives powershell commands to check if SMB1 is on or off

It turns out the powershell commands given in the referenced article won’t run on my desktop, they only run under Windows Server, not Windows 10. I tried to figure out how to enable them in Windows 10, but, after looking for 30 minutes, decided to abandon the search.

I’ll just assume SMBv1 was disabled on my computer during a recent Windows 10 update.

Thanks for the help.

Hi,

Just tried the powershell commands on my windows 10 vm and it does look like the docs provided my microsoft could do with an update. Anyway you should be able to check/re-enable smb1 via Turn Windows features on and off:

Thanks Tom.

Thanks Tom.

I checked the link you provided and navigated to the “turn Windows features on or off” option in “Programs and Features” in “Control Panel”.

Yep. SMB1 had been disabled (it wasn’t checked). I left it disabled, since I can access my files now, having reset my OSMC options to use SMBv2 or SMBv3.

I was able to access all my files a couple months ago, so SMBv1 was enabled then. (I don’t remember the last time I had accessed these files.) So, some Windows update in the past 2-3 months ended up disabling SMBv1.

1 Like