Upgraded Server to Ubuntu 20.04LTS. Any Samba changes? [Solved]

Upgraded my linux box to Ubuntu 20.04 yesterday. Today I’ve noticed that my Pi’s are no longer mounting my two samba shares through fstab.
My two entries are:

// /mnt/VIDS cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.smbcredentials,vers=3.0,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0
// /mnt/MUSIC cifs x-systemd.automount,noauto,rw,iocharset=utf8,credentials=/home/osmc/.smbcredentials,vers=3.0,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

Even dropping back to the old method of “username=xxx,password=xxx” doesn’t work. The command “mount -a” returns no errors, but the two folders are empty. A share on a Windows 10 machine works fine, so I can only assume it’s a change in samba on my server. Has anyone heard of this?

As an aside, I do have NFS shares that work. Does NFS cause more or less of a performance hit on the Pi?

Nfs has far less overhead so if that’s working you would be better using that.

1 Like

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

NFS should be better for performance/throughput.

Thanks Tom.

Install smbclient sudo apt-get install smbclient

Then run smbclient -L

But as others mentioned if only Linux systems are accessing the server then NFS is better.

Well anything that reduces the hit on the Pi is good for me, so I’ve just left the NFS connections for now. I figured it was to do with the upgrade on the server because they disappeared on both Pi’s after the server had rebooted and never came back. I’m not really bothered, I’ll just switch them all over to NFS. I just thought someone might have noticed it and found the reason, which would save me googling around for hours.

And…here’s the answer. So it is Ubuntu 20.04. Probably no longer supporting SMBv1.


My problem was caused by a Windows 10 update that removed support for SMB v1, as reported above in this thread. I had OSMC set to use SMB v1 only, so I couldn’t access the shares. I changed the OSMC setting to use any version of SMB and my problem was solved.

Yes, and my problem was obviously caused by a linux update that did the same. Because my shares are on a linux box.