SMB server I get the error 2 “resource not available”


#1

Hi.
Maybe this has already been talked about. but why now every time I want to look for my SMB server I get the error 2 “resource not available” as I understand it is because of the new security of SMB before attacks.
but what would I have to do to enter my SMB service?
Thank you!


Play content from another multimedia
#2

Hi,

Is your SMB Server an OSMC device or a WIndows Device?

Thanks Tom.


#3

Hi. my server I have it in a popcorn a410 always worked until it happens to NFS. but today I need that SMB server and I found that error.


#4

Ah okay. I did not understand the question, sorry.
my device is a Vero 4K


#5

Hi,

Where are samba shares hosted?

Vero4k or the popcorn a410?

Thanks Tom.


#6

I have the files in the popcorn. This same has the Samba server activated. I want to access it from the Vero.
by NFS there is no problem but when doing a search by SMB I get that error.
A couple of months ago there was no such problem in Vero. Maybe some update …

Thanks for everything!


#7

Hi,

I would try changing Maximum protocol version to SMBv2 or SMBv1 on the vero, you can find it under:

Settings, Services, SMB Client.

Thanks Tom.


#8

Hi.
Again the “Error 2” jumps me when trying to search for samba in the Vero 4K.
I have changed the protocol and tried with the 3 options and keeps jumping the error. It has always worked with the default 3, I do not know why that happens.

Thank you!


#9

Hi,

Any updates or changes of settings on the popcorn?

Thanks Tom.


#10

No.
Nothing, I have not touched anything or there have been updates. I just wanted to update my music folders by samba, since I noticed that some tracks did not appear.

thanks and regards!


#11

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device

  • reproduce the issue

  • upload the log set either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

Regards Tom.


#12

Thank you!!

I do not know if I have done well …

Https://paste.osmc.tv/ibawilowaj


#13

Hi,

SMBDirectory->GetDirectory: Unable to open directory : 'smb://'
                                            unix_err:'2' error : 'No such file or directory'

Browsing has doesn’t work for smb3. I suggest changing to SMB1 on both osmc and the popcorn device, add the shares on osmc; then change back to smb3 on both devices.

Thanks Tom.