SMB share issues between OSMC and W10

All configs/logs:


SMB host added through app store.

I can see my Pi on the network; SMB server is working fine.

My OSMC can not browse, nor can i input a valid share URL such as:

23:04:38.275 T:1958748160 ERROR: SMBDirectory->GetDirectory: Unable to open directory : ‘smb://’
unix_err:‘1’ error : ‘Operation not permitted’
23:04:40.578 T:1958748160 ERROR: GetDirectory - Error getting smb://

I used to be able to browse the windows workgroup and machines in the past; but when I restored my Pi’s SD card to use OSMC again, it needed the folder share locations updated because I had since reformatted and renamed things on my pc. This is where I ran into the issue of not being able to browse SMB shares given I can see the SMB share from the pi on my machine.

I am using windows 10 to share the folders. I have tried with/without password protected sharing. With/without homegroup sharing. and I have tried high and low encryption settings.

I have read many other posts here about similar issues, but no answers worked for me.

Thanks for the input.


Have you recently updated windows 10?

Browsing is a feature of smbv1, which has recently been disabled in windows 10.

Thanks Tom.

This is expected as SMBv1 has been disabled for security reasons.

This should still work. I suggest you either try fstab based mounts or use smbclient on the command line to figure out if you can access the Win10 from command line

Is there a simple command line mount I can perform to test?

I do have a SSH window open to the Pi.

For fstab mount check this

You also can try smbclient -L -u User SERVERbut you would need to install smbclient first

error: no such device

When I try to browse the fstab mount.

when I ran this command:
smbclient -L -U my_username

it connected but errored out:

osmc@RaPi:~$ smbclient -L -U Z270
Enter Z270’s password:
Domain=[Z270-PC] OS=[Windows 10 Pro 15063] Server=[Windows 10 Pro 6.3]

    Sharename       Type      Comment
    ---------       ----      -------
    3.0TB-Videos    Disk
    ADMIN$          Disk      Remote Admin
    C$              Disk      Default share
    D$              Disk      Default share
    E$              Disk      Default share
    E-Recordings    Disk
    F$              Disk      Default share
    F-My Stuff      Disk
    IPC$            IPC       Remote IPC
    J$              Disk      Default share
    J-Movies        Disk
    K               Disk
    K$              Disk      Default share
    L$              Disk      Default share
    Users           Disk

Connection to failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
NetBIOS over TCP disabled – no workgroup available
osmc@RaPi:~$ sudo systemctl daemon-reload
osmc@RaPi:~$ sudo systemctl restart
osmc@RaPi:~$ cd /mnt/Movies
-bash: cd: /mnt/Movies: No such device
osmc@RaPi:~$ sudo mount /mnt/Movies
Couldn’t chdir to /mnt/Movies: No such device

Also note:

All typos as per above notes have been corrected (the movies folder name) as I have renamed some of the shares that being one of them; thus its not seen the same in the printout directly preceding this note.

Create the mount point:

sudo mkdir /mnt/Movies
sudo chmod 777 /mnt/Movies

But if you follow the linked tutorial you will not need to create the mount point.

What does your fstab look like?

I did follow the tutorial. mount -a returns no error… smbclient can connect, but gives the error shown in my previous post.

I had not chmod 777 on the /mnt/Movies folder, but doing that and re initializing had no change.

I’d like to see your fstab please.

It’s in that log i posted above. Only thing is before i submitted the log, I changed the password in it.

====================== fstab =================== qiE9Dtax
/dev/mmcblk0p1 /boot vfat defaults,noatime 0 0
/dev/mmcblk0p2 / ext4 defaults,noatime 0 0
// /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=Z270,password=,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770 0 0

---------------------- fstab END --------------- qiE9Dtax

Based on this list there is no share called “Movies” on your server

found my typo. The mount now works. Thanks!

Somehow it got removed, I remember typing it earlier.

Ok, so you are trying to mount Movies, but there is no share Movies share! Maybe you are trying to mount the J-Movies share?

Part of my typo was the fact that I forgot I renamed a share on my host machine.

The final result of this whole issue:

The SMB function simply can’t be used to browse out; but the SMB server works fine.

I had to create a mount point,

sudochmod 777 /mnt/movies

add the fstab mount information as per above tutorial

then I was able to add the local directories as folders in the osmc GUI.

So for people trying to use the smb:// feature; looks like its simply not worth the time. It used to be the easy way to do it. I tried to get the smb:// feature to work so I could browse, but at this point, i give up and will settle with this.

But thanks again to everyone whom replied.

fstab is faster; you will be happier with it. You probably didn’t need to create the mount point, with the automount it will be created when you boot your system.

The SMB removal of browsing of shares was a security issue, as you probably know.

yeah, my use is all on my local network; I have no security concerns. I am in a very rural area.

OSMC is nice because I can just plug a Pi directly into a projector; throw up a sheet, and watch literally anywhere with my long range AP.

Same here :smiley: