SMB, Synology not permitted


i used OSMC with a Synology NAS, to see my folder, today I use sources.xml files and i would like use SMB since the GUY but when i launch “Add A source”/“Browse”/“Windows Network (SMB)”/“WORKGROUP”/“My NAS” i have an error “Operation not permitted”

My Synology is under SMB V3

lock directory = /home/osmc/.kodi/.smb/
client max protocol = SMB3
name resolve order = bcast host
include = /home/osmc/.kodi/.smb/user.conf

How resolved this issue ? (I don’t want use NFS)



Any particular reason? NFS provides better throughput & would probably easier to setup in this scenario.

Anyway SMBv3 doesn’t support browsing, if the synology supports its try changing to SMBv1 add the shares; then revert back to SMBv3. Or add the shares manaully to sources.xml. Another option is the mount the shares via fstab or autofs.

Thanks Tom.