SMB Transfer speeds

So Finally got the Vero4k+ a few days ago and now having a bit of difficultly with sharing some larger bit rate files. In this case about 100Mb/s. For some reason when setting up smb I had to use smbv1 as all the others failed to play any files although it would let me browse the directories. I also do not have a NAS just a mac running Catalina 10.15.7 with a few drives connected to it. It’s a hackintosh but I fail to see how that would matter for this. Anyways is SMB v2 or v3 any faster and if so I wonder why it wont connect with v2 or v3. Also the mac and vero are on Gb ethernet so that’s not the bottleneck. Any ideas? Thanks

Edit: It will play these files but it buffers for a while and stutters and has to buffer again shortly after playback begins.

Have you tried setting

Settings->Services->SMB Client->Mitigate MTU issue with smb2

(you need to set the setting level to advanced or higher)

This would explain the symptoms you describe with smb2. Don’t know whether your mac solution provides smb3.

For performance reasons I suggest you mount the smb shares in the root file system, have a look here Mounting network shares with autofs (alternative to fstab)

I will give the MTU setting a shot and yes I am set to advanced or expert. Also I am not sure if it’s the problem is with smb2 or 3 as neither seem to work. I also have seen the autofs page but it’s a bit above my head for now. Also from what I have read my mac should support all 3 versions. Keyword should.

Thanks but that did not help. Also getting function not initiated warning when trying smbv3.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • enable component-specific logging for the SMB library

  • enable event logging and notification event logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshots:

Thanks Jim,

Hopefully I will have time later tonight to submit some logs as well as wrap my head around using the autofs command. Thankfully this issue is very rare but one I would like to fix. It’s raw gopro files so almost 4g for 8mins not something I often watch on the big tv however I would like to from time to time.

Mmmhh, that rings a bell, see Gopro Hero 6, Stuttering Video - #26 by JimKnopf … but this should be fixed already.

Could you also put one of these gopro files on a USB stick and try to play it with the stick inserted into the Vero? If it is the same issue, it’s not realted to the network/smb/etc. at all but soemthing special with the gopro file format like that issue from 2018.

I will however I highly doubt that is the issue as once the file has buffered a bit it plays perfectly until the buffered data is eaten up. Looking at the network meter on the mac I can see throughput is just a bit below the bit rate of the file.

Did this solve the problem?


No sorry long weekend here hope to have some free time tonight to grab the logs etc…


I don’t know much about Apple stuff, but Unix systems should probably use the native NFS for network files, not CIFS. NFS tends to work better for OSMC, IME,
just run a DLNA server on the Mac and use OSMC as a DLNA client+renderer?

I do both, this removes all the funky things that MSFT does with the CIFS stuff and all the Apache-samba guys attempted responses from our concern.

There are a number of good DLNA servers for Linux. I’d assume they work on Apple too.

I have to agee on this. Never, ever mount a network share with Kodi. I haven’t tested what Kodi does and honestly I don’t really care at this point, but it was more than 10x slower than just mounting it via fstab.

Also, I suggest to use version 3.0 of smb.

here’s an example:

//IP-OR-HOSTNAME/Multimedia/Movies /mnt/Movies cifs x-systemd.automount,noauto,rw,iocharset=utf8,username=SMBUSER,password=SMBPASS,uid=osmc,gid=osmc,file_mode=0770,dir_mode=0770,vers=3.0 0 0