SMB1 issue

I have sucessfully shared the hard drives on my windows 7 PC, using SMBv1, as per the guide here.

I had to use powershell on the pc to do the SMB stuff as the ’ widnwos box’ was empty but this does not seem uncommon.

All works fine. The guide says after doing the shares one should revert to SMB3, for security. As soon as I do this the shares is lost. I get various error messages, but it is gone, as soon as I go back to SMBv1 all is good.

Is this normal ?
How bad is the risk with SMBv1

Thanks

Well SMB1 is not secure not performant and should only be used if there is not other options. But as both Win7 and OSMC support higher SMB versions you should stay away from SMB1.

I would suggest to change all parts where you configured SMB1 (on Win 7 and OSMC). And then configure the connection once more.
How did you establish the connection did you just configured it via OSMC/Kodi or did you use the fstab/autofs mounting?

Also last but not least I suggest to think about moving away from Win 7 which is also not a secure OS anymore.

Thanks, I will give it a go. From the guide I referenced I thought I had to use SMBv1.
I added the share using the drop down in the vero 4k, and found homegroup.

Staying with win7 for the moment. I can get at all my files using servioo so the file share is just a bonus.

You only would need to use SMB1 if you want to use the browsing function to find the share. But if you manually configure it no need to use browsing function (SMB1)

Thanks, I had only been using browse, and found exactly what you said. After you post I have found the guide below and wil have a go at that.

https://kodi.wiki/view/SMB

Great let us know if you have any problems

Windows 7 and SMBv1 is a high security risk, wouldn’t use them either.

Worked a treat when not using browse, thanks

When you click on browse their is an option to add a network location. If you use this to manually add your network source (ie add just the machine name or IP address and not include the share path) and credentials, then instead of going to “browse>windows network” you “browse>[network source you added]” then you will be able to “browse” that network location to add sources.

Thanks I did exactly that, and added about 10 folders each the same way.
The funny thing is only one of the 10 shows near the top of the home screen under TV Shows.

If I go home>videos>catogories>TV shows, I see that one show
if I go home>videos>catogories>files I all 10
home>videos>catogories>media sources I see 2 of the 10.

I can play all the videos via the files option above, seems odd >

Sounds like you didn’t set content on all the sources you added. Also if you only see a single show then make sure you didn’t check the option for ‘folder only contains a single show’ in the scraping settings.

Your post also makes it sounds like your doing something non typical. Normally you would have one or several shares that contain all your TV shows. Are you adding individual sources for each show?

Providing logs will show us exactly how you have your shares configured.

I am clearly falling at the last step. I have 3 shares each with a few sub folders in. Each share appears in media sources and the folders and files can be accessed from files. Nothing is in TV shows A-Z , is there a guide to this last step? I have checked and the content type is right.

You mean this?

https://kodi.wiki/view/Adding_video_sources

As ActionA stated, if you were to provide logs…

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

then this would provide us some insight that may allow us to help you better.

Thanks l feel l should be able to sort it from a guide without resorting to a log

I went through the adding video sources for a single folder as per the instructions, and had the problem again, in that I can see the files in file mode but they are not in the library. I then deleted them and did it again with loging on, link below.

One thing that really stands out is that at at step 5 of adding the videos
Browse to locate your Source folder. Enter the Source folder so you see your titles. Select.

The video files are not visible there, although they are in the folder on the pc and playable on the Vero via the file option. I suspect this is the root cause ?

Log is here

https://paste.osmc.tv/sohomafovu

When you are setting a source, it is intended that you are not able to see the files. During this operation you are setting a location (a folder) and seeing individual files is not relevant.

Where the guide is advising where you see your titles, I suspect it’s assuming that your files are in individual folders. This is how my movie folder is structured, but everyone’s may not be.

You cannot add UPnP sources to a library so any of those are expected to not scan. The one non-UPnP source you have is pointing directly to an individual show when it should be pointing to its parent folder. In addition to that, the one TV show that you did point it to is named incorrectly enough that without the aid of a nfo file I would expect it to fail. As dashes are a normal bit of punctuation they are not acceptable for exchanging for a space. You can use a space, an underscore, or a period, but not a dash inside of a title that it does not belong to. You should also reference a shows name with the scraping source in doubt so you can find things such as “Batwoman” being a single word.

Thanks to all.
I added servioo as a source as soon as I got the Vero, as I could do that directly out of the box. I knew that servioo would not interface with the library, but did not know that having servioo access files, would prevent the library accessing them when they were shared another way as well. I have removed servioo, and got the library working, with just a few tweaks to names etc.

Glad you got it going, but just to be clear, you can have UPnP sources and they will not interfere with the library. They just are limited to being directly accessed and not able to be scrapable sources themselves. There should be no issue if you had both SMB paths and UPnP paths that touched the same files.