[Solved] Add Network Location problem Vero 4K


I have

  • LinkStation,
  • Vero 4K,
  • Windows 10 PC

all on the same wired network

PC can see both Linkstation shares and Vero 4K shares (Samba Server installed)

However when I am trying to go to Vero 4K to:

Videos > Files > Add Videos > Add network location
Settings > File Manager > Add source > Add Network Location

and enter the IP address of Linkstation, it says “connection timed out” right away

if I use Vero 4K own IP address, then it can see the files.

what am I doing wrong there (LinkStation IP is

16:28:17.054 T:4109881344   ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://'
                                            unix_err:'6e' error : 'Connection timed out'
16:28:17.054 T:4109881344   DEBUG: ------ Window Init (DialogConfirm.xml) ------
16:28:18.698 T:4109881344   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
16:28:18.831 T:4109881344   DEBUG: OnKey: return (0xf00d) pressed, action is Select
16:28:18.831 T:4109881344   DEBUG: Keyboard: scancode: 0x1c, sym: 0x000d, unicode: 0x0000, modifier: 0x0
16:28:19.100 T:4109881344   DEBUG: ------ Window Deinit (DialogConfirm.xml) ------
16:28:19.126 T:4109881344   ERROR: GetDirectory - Error getting smb://
16:28:19.126 T:4109881344   DEBUG: ------ Window Init (DialogConfirm.xml) ------

if, from Vero 4K, I try to access a shared folder that is on Windows 10 PC, it says “Operation not permitted”

SMB browsing for legacy devices (SMBv1) doesn’t work since the recent security updates. These updates come after the WannaCry malware.

You can add the shares directly; or use fstab. But browsing SMBv1 shares is no longer supported. Your device may have a firmware update to support the new version of SMB.

Linkstation most likely only supports smb1, see this thread

I can see that LinkStation has SMB 2 on:

changing smb.conf to SMB1 solved the problem.

i tried to change back to SMB2 and restart and the problem re-appeared. So I will stick with SMB1 for now.

is there a way to query a network location and see which version of SMB it is using?


I am still searching for an answer. You could try nmap sudo apt-get install nmap and then nmap -sV -p 139 <SERVER IP>

Alright, I opened shares from Windows 10 Notebook to both LinkStation and Vero 4K.

then I used PowerShell to get the connection properties:

result: is the address of Vero 4K that uses SMB 3.0 is the address of LinkStation that uses SMB 2.0.2

so, that confirms that LinkStation is using SMB 2 and Vero 4K does not want connecting to that.

That is really odd. @sam_nazarko is in the moment looking into releasing Kodi 17.4 with the next update which brings some changes to the Samba Client. So you might want to wait for that release or if you are willing to help us testing and not afraid of breaking something could try the current staging version.

I am really a novice in the Linux area and afraid I could bring more questions than actual help. I will wait for an update :slight_smile: and stay with SMB1 for now.

Is it worth trying client min protocol = SMB1.0.1 or SMB1.99 or something to say that it should be 1+? Would it brake something?

Could it be that osmc is not accepting any SMB that is lower than own (3.0) version?


Nothing you can break so try it.
Actually just found this.
SMB2: Re-implementation of the SMB protocol. Used by Windows Vista and later versions of Windows. SMB2 has sub protocols available. SMB2_02: The earliest SMB2 version. SMB2_10: Windows 7 SMB2 version. SMB2_22: Early Windows 8 SMB2 version. SMB2_24: Windows 8 beta SMB2 version. By default SMB2 selects the SMB2_10 variant

So try SMB2_02

Yes! SMB2_02 works.


1 Like

Well good to know, let’s see how it goes with 17.4

hey, which process did you follow to do this?
talk to me like i’m 5 yo :slight_smile:

I will try my best. it is like a 6 yo teaching 5 yo :slight_smile:

The first step would be to establish SSH connection to Vero 4K via Putty or any SSH tool:

The second step is to edit the configuration file that holds the version number of SMB to be used:

File sharing with a NAS, media server, windows share or other device
To force a more secure protocol, add server min protocol = SMB2_10 to the [global] section of smb-local.conf.

so that would be with SMB2_02 in my case:
sudo nano /etc/samba/smb.conf

I haven’t touched the file since August, and a couple of updates came in after that. I do not see the setting that i have set there anymore on my Vero. It could be that one of the updates replaced the file and the setting was removed. Accessing the files from the share still works, which probably means that it should work out of the box now.

Probably not. Once a connection has been established, and security keys exchanged, Windows seems happy. It is establishing the connection in the first place that is a problem.

Aha, interesting. I have a NAS (LinkStation) that is probably running Linux, but the same rules apply then. So, it looks the setting up for establishing the first connection. Then it is sort of in the “address book” and “auto-dials” from now on. Good to know. Thanks!

Yes, any change to network environment (IP addresses eg), re-imaging your device, or some Windows ‘upgrades’ can put you back to square one.