(Solved) Advancedsettings on pi2 for kodi 19.4

<?xml version="1.0" encoding="utf-8"?>
<advancedsettings version="1.0">
	      <!-- <cd/dvd/part/pt/disk/disc> <0-N> -->
	      <regexp>(.*?)([ _.-]*(?:cd|dvd|p(?:ar)?t|dis[ck])[ _.-]*[0-9]+)(.*?)(\.[^.]+)$</regexp>
	      <!-- <cd/dvd/part/pt/disk/disc> <a-d> -->
	      <regexp>(.*?)([ _.-]*(?:cd|dvd|p(?:ar)?t|dis[ck])[ _.-]*[a-d])(.*?)(\.[^.]+)$</regexp>
	      <!-- movienamea-xvid.avi, movienameb-xvid.avi -->
	      <regexp>(.*?)([ ._-]*[a-d])(.*?)(\.[^.]+)$</regexp>

My sound with music stutters… can I change anything?

The only setting you have there that relates to playback is the cache settings and that would be an unlikely factor for audio only. Additionally you have provided very little to go off of as you didn’t even state what type of audio you were playing and from where. Also logs.

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding. We hope that we can help you get up and running again shortly.

OSMC skin screenshot:

here are my logs:
My pi is connected via HDMI to TV
My skin is Estuary

I wasn’t seeing where you had turned on debug logging and played a music file that was stuttering.

Did delete the MyMusic.db and rescan the source. Now many soundfiles skip because of “failed to create the decoder”. Debuglog is

I think the memory is set too high. After some testing now it works with this:


Thank you for helping.