[solved] Can't access network, Rasp Pi 2, using 8-1 image

I installed the Aug 1 Raspberry Pi 2 image on a RPi2. Under system/info, I see it has a network IP address assigned by my router, but it saids:

Link: connected
mac address: xx:xx:xx…
IP address;
internet: busy / not conntected, check network settings

I’m not sure why the internet setting keeps going from busy to not connected. I’m connected via hardwired ethernet cable to the router. Other things connected to the same set of ports are fine (my laptop).

I also can’t ping the Pi.

When I use other images on the exact same Pi setup (Raspbian), no problems with internet. So it’s definitely something with the interaction between the 8-1 image and my setup.

Edit2: image from July works. Network is fine with exactly the same setup. Seems only the latest 8-1 image has the network issue.

I’d suggest uploading some logs so we can take a better look at the issue

dmesg, connmanctl services, ifconfig would be good


If your network connection is not working, use the My OSMC log uploader to save all logs to the SD card. This will create a file called uploadlog.txt on the FAT partition that you can copy to a PC then paste to paste.osmc.io.

1 Like

I found the issue. I needed a static DHCP for some reason. So no fault with OSMC, totally my own. Not sure why it worked with Raspbian image but not OSMC when I was testing. But problem fixed.

If DHCP did not work but it does for other devices on your network, that is still a bug that we would like to identify and fix.