[SOLVED] Can't access OSMC with windows explorer


#1

I’ve just setup OSMC 2018.07-1 with LibreELEC on a Raspberry Pi 3b. I have it all working well except I can’t access OSMC from windows 10. I’ve done a lot of searching of the forums and I’ve enabled SMB v1 on windows, but I still can’t access OSMC.

I’ve tried \192.168.x.x\ and \osmc, but I always get an error that windows can’t access it. I know I have the IP correct as I can connect to OSMC through a web browser at the same IP. I’ve also tried browsing the network, but OSMC doesn’t show up while other network devices do. I confirmed the workgroup is set correctly on both the pc and the OSMC install.

It works fine the other way and I can access an SMB share on windows from OSMC just fine. I tried creating a smb-share.conf as well just in case, but I know OSMC is supposed to share some folders automatically. Ultimately I’d like to share a usb HDD attached to the pi, so I can add media to it from windows and not require the pc to be on to stream from.

Thanks a lot for any suggestions!


#2

Have you installed SMB server from the AppStore?


#3

No. You’ve setup OSMC on a Pi 3b that includes Kodi. Nothing about this is LibreELEC.


#4

Assuming you installed OSMC on a RPi and not LibreElec…

Did you ever see a popup on Windows asking for login credentials when accessing the OSMC share? You should and fill in osmc as user and pw. It works perfectly fine here.


#5

I just got it going! I was looking for the SMB server in the app store, but I was in the wrong app store. It was the Kodi app store in the ‘program’ and ‘services’ addon section. I just found it in the AppStore for My OSMC and installed it. Thanks a lot!

Now does OSMC support ntfs read/write? I know it supports fat32, but I’d like to get a larger volume going with an attached usb hdd. It would be handy if I could unplug it and use it natively on windows. I hear an ext4 driver can be used with windows 10, but I don’t have any experience with that and I don’t know how well it works.

Thanks again everyone for your help!


#6

Plugging a NTFS drive in works out of the box, read and write :slight_smile:


#7

Avoid. NTFS will do you nicely on RPi.


#8

That’s good news! Thanks for the info :slight_smile: